On 2014/11/12 13:41:14, marja wrote:
https://codereview.chromium.org/663683006/diff/400001/src/parser.cc
File src/parser.cc (right):


https://codereview.chromium.org/663683006/diff/400001/src/parser.cc#newcode5093
src/parser.cc:5093: for (int i = 0; i < cookedStrings->length(); ++i) {
On 2014/11/12 13:33:12, caitp wrote:
> On 2014/11/12 09:23:21, marja wrote:
> > Gets confusing with i, c and j; could you rename i to string_index or sth,
> then
> > j could be raw_chars_from_index and c could be raw_chars_to_index. Or
> something
> > along those lines.
>
> Done. (I'm not sure this is much easier to read, though)

Yeah, they're kinda long. How about just to_index and from_index? Or to and
from?

Ah, that's actually exactly the identifiers I used, what a coincidence. I've
moved it into a separate function and made it a bit easier to read, I think it's
clearer now.

https://codereview.chromium.org/663683006/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to