lgtm
https://codereview.chromium.org/968263002/diff/240001/src/scopes.cc
File src/scopes.cc (right):
https://codereview.chromium.org/968263002/diff/240001/src/scopes.cc#newcode1453
src/scopes.cc:1453: Variable* Scope::ClassVariableForMethod() const {
Nit: move this next to CheckStrongModeDeclaration
https://codereview.chromium.org/968263002/diff/240001/src/scopes.h
File src/scopes.h (right):
https://codereview.chromium.org/968263002/diff/240001/src/scopes.h#newcode514
src/scopes.h:514: // Some block scopes are tagged as class scopes.
Yeah, I think this is fine for the time being, but it strikes me as
somewhat hacky. Classes aren't blocks. Long term, we should probably
rethink the way we distinguish various scope types. It might make sense
to have subtypes there, but then the naming should be properly adjusted.
I'm not yet convinced it's worth it, though.
https://codereview.chromium.org/968263002/
--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
---
You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/d/optout.