We added `IsValueObject` to align with `java.util.Objects::isValueObject`, but that API has been streamlined and now only has `hasIdentity`. Consequently the JNI method should be renamed to `HasIdentity`.
The terminology and semantics are aligned with `Objects.hasIdentity`, which means `HasIdentity(null)` is false, whereas previously `IsValueObject(null)` was false. Elsewhere variable names are changed and test logic is negated. Testing: - valhalla tests (hotspot/runtime, JDI, serviceability) - tiers 1-3 sanity Thanks --------- - [x] I confirm that I make this contribution in accordance with the [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai). ------------- Commit messages: - 8383884: [lworld] Rename JNI IsValueObject to HasIdentity Changes: https://git.openjdk.org/valhalla/pull/2393/files Webrev: https://webrevs.openjdk.org/?repo=valhalla&pr=2393&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8383884 Stats: 207 lines in 12 files changed: 93 ins; 93 del; 21 mod Patch: https://git.openjdk.org/valhalla/pull/2393.diff Fetch: git fetch https://git.openjdk.org/valhalla.git pull/2393/head:pull/2393 PR: https://git.openjdk.org/valhalla/pull/2393
