On Wed, 6 May 2026 02:38:28 GMT, David Holmes <[email protected]> wrote:
> We added `IsValueObject` to align with `java.util.Objects::isValueObject`, > but that API has been streamlined and now only has `hasIdentity`. > Consequently the JNI method should be renamed to `HasIdentity`. > > The terminology and semantics are aligned with `Objects.hasIdentity`, which > means `HasIdentity(null)` is false, whereas previously `IsValueObject(null)` > was false. Elsewhere variable names are changed and test logic is negated. > > Testing: > - valhalla tests (hotspot/runtime, JDI, serviceability) > - tiers 1-3 sanity > > Thanks > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai). jdwp changes look good ------------- Marked as reviewed by cjplummer (Committer). PR Review: https://git.openjdk.org/valhalla/pull/2393#pullrequestreview-4238748193
