On Wed, 6 May 2026 02:38:28 GMT, David Holmes <[email protected]> wrote:
> We added `IsValueObject` to align with `java.util.Objects::isValueObject`, > but that API has been streamlined and now only has `hasIdentity`. > Consequently the JNI method should be renamed to `HasIdentity`. > > The terminology and semantics are aligned with `Objects.hasIdentity`, which > means `HasIdentity(null)` is false, whereas previously `IsValueObject(null)` > was false. Elsewhere variable names are changed and test logic is negated. > > Testing: > - valhalla tests (hotspot/runtime, JDI, serviceability) > - tiers 1-3 sanity > > Thanks > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai). This pull request has now been integrated. Changeset: 800190d2 Author: David Holmes <[email protected]> URL: https://git.openjdk.org/valhalla/commit/800190d208d2be7dcb7da45d00590bbdc177cd42 Stats: 207 lines in 12 files changed: 93 ins; 93 del; 21 mod 8383884: [lworld] Rename JNI IsValueObject to HasIdentity Reviewed-by: phubner, cjplummer ------------- PR: https://git.openjdk.org/valhalla/pull/2393
