On Wed, 6 May 2026 12:25:29 GMT, Paul Hübner <[email protected]> wrote:

>> We added `IsValueObject` to align with `java.util.Objects::isValueObject`, 
>> but that API has been streamlined and now only has `hasIdentity`. 
>> Consequently the JNI method should be renamed to `HasIdentity`.
>> 
>> The terminology and semantics are aligned with `Objects.hasIdentity`, which 
>> means `HasIdentity(null)` is false, whereas previously `IsValueObject(null)` 
>> was false. Elsewhere variable names are changed and test logic is negated. 
>> 
>> Testing:
>>  - valhalla tests (hotspot/runtime, JDI, serviceability)
>>  - tiers 1-3 sanity
>> 
>> Thanks
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> LGTM. Thanks.

Thanks for the reviews @Arraying and @plummercj !

-------------

PR Comment: https://git.openjdk.org/valhalla/pull/2393#issuecomment-4417098953

Reply via email to