Regis; 

I am having the same problem as you, only that I use courier-imap's 
pop3-ssl... I included the following lines in my vpopmail configuration: 

 --enable-roaming-user=y
 --enable-tcpserver-file=/home/vpopmail/etc/tcp.smtp
 --enable-relay-clear-minutes=60 

I run qmail-smtpd with the following line (from lifewithqmail but with the 
path to tcp.smtp modified: 

exec /usr/local/bin/softlimit -m 4000000 /usr/local/bin/tcpserver -v -R -l 0 
 -x /home/vpopmail/etc/tcp.smtp.cdb -c
"$MAXSMTPD" -u "$QMAILUID" -g "$NOFILESGID" 0 smtp 
/home/qmail/bin/qmail-smtpd 2>&1 

I have the following files in /home/vpopmail/etc: 

 -rw-rw-r--    1 vpopmail vchkpw         83 Sep 25 19:13 tcp.smtp
 -rw-rw-r--    1 vpopmail vchkpw       2179 Sep 25 22:40 tcp.smtp.cdb 

...and I still only relay when I manually modify the tcp.smtp! I am lost, 
please... if anyone has ideas about this I will be very grateful =/ 

Thank you... 

Miguel 

 

 

rm escribió: 

> After several months of getting by with sqwebmail for remote users,
> we've decided to add the "enable roaming users" option.  It seemed
> simple enough in reading the docs and the archive messages on this
> subject.  But I seem to have missed something. 
> 
> My configure line is:
> ./configure  --enable-roaming-user=y
> --enable-tcpserver-file=/home/vpopmail/etc/tcp.smtp
> --enable-relay-clear-minutes=60 --enable-mysql-logging=y
> --enable-clear-passwd=y --enable-incdir=/usr/include
> --enable-libdir=/usr/lib --enable-mysql=y --enable-mysql-replication=y
> --enable-valias=y 
> 
> I modified the smtp run file to use the correct path to
> /home/vpopmail/etc/tcp.smtp - originally I used the "life with qmail"
> example - so the modified file looks like this: 
> 
> #!/bin/sh
> QMAILDUID=`id -u qmaild`
> NOFILESGID=`id -g qmaild`
> MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
> LOCAL=`head -1 /var/qmail/control/me`
> if [ -z "$QMAILDUID" -o -z "$NOFILESGID" -o -z "$MAXSMTPD" -o -z
> "$LOCAL" ]; then
>     echo QMAILDUID, NOFILESGID, MAXSMTPD, or LOCAL is unset in
>     echo /var/qmail/supervise/qmail-smtpd/run
>     exit 1
> fi
> exec /usr/local/bin/softlimit -m 4000000 \
>     /usr/local/bin/tcpserver -v -R -l "$LOCAL" -x
> /home/vpopmail/etc/tcp.smtp.cdb -c "$MAXSMTPD" \
>         -u "$QMAILDUID" -g "$NOFILESGID" 0 smtp
> /var/qmail/bin/qmail-smtpd 2>&1 
> 
> I copied the tcp.smtp and the tcp.smtp.cdb file from /etc into
> /home/vpopmail/etc 
> 
> I also tried to add > /dev/null &  at the end of the smtp run file, as
> shown in the FAQ example; but when I add that - the smtp server won't
> start. 
> 
> In any event - remote logins keep getting the error message "recipient
> not in allowed rcpt hosts" when they try to send mail. 
> 
> Any ideas on what I've missed here? 
> 
> Thanks, 
> 
> Regis 
> 
>  
> 
> 
 

Reply via email to