On 29.10.2002 21:27 Uhr, "David Phillips" <[EMAIL PROTECTED]> wrote:

> tcp.smtp (compiled into tcp.smtpd.cdb) controls which IP's are allowed to
> connect to tcpserver.  It defaults to allow (which would be a single
> ":allow" line).  Setting RELAYCLIENT for an IP tells qmail-smtpd to allow it
> to relay mail.
Ok. Got that.

> Normally, this file contains all IP's on your network, assuming you want
> them to relay through qmail.  The following is an example.  RBLSMTPD is only
> needed if you are using rblsmtpd.  Leaving it blank tells rblsmtpd to not
> perform lookups against that address (you don't want it looking up your own
> addresses):
> 127.:allow,RELAYCLIENT="",RBLSMTPD=""
> 192.168.:allow,RELAYCLIENT="",RBLSMTPD=""
Well obviously I forgot the '127.:...' entry. Now it works fine locally. I
will jut go an try online now.

>> My run file is (I just changed the path of the vpopmail-home):
> If your domains directory is on /var, then make sure you have enough space
> for all the mail.
Yes I will do so.

>> #!/bin/sh
>> QMAILDUID=`id -u qmaild`
>> NOFILESGID=`id -g qmaild`
>> MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
> As a tip, you can get rid of QMAILDUID and NOFILESGID by adding -U to the
> tcpserver command line and using "envuidgid qmaild" as the first thing after
> exec.
What will this help me?

>> exec softlimit -m 2000000 \
>>   tcpserver -v -R -l 0 -x /var/lib/vpopmail/etc/tcp.smtp.cdb -c
>> "$MAXSMTPD" \
>>     -u "$QMAILDUID" -g "$NOFILESGID" 0 smtp qmail-smtpd 2>&1
>> When I try to send a message I get the 5.7.1 error.
>> I read all the documentation for Newbies on relaying from Chris.
> Does your tcp.smtp file set RELAYCLIENT for the IP that you are sending
> from?
Yes, I got '127.: ...' and '192.168.0.:... ' as an entry.
Now on my online setup I got the following problem:
In my office I am sitting behind a firewall. I got a t1 connection but I do
_not_have_a fix IP.

I am obviously sending mails only from the domains listed in rcpthosts but
somehow I still get the 5.7.1 error! Argh.

> vpopmail will create vpopmail/etc/open-smtp that it merges with tcp.smtp
> when building tcp.smtp.cdb.  It does this automatically for any IP that
> successfully authenticates via POP3 (or anything using vchkpw, such as
> Courier IMAP).  tcp.smtp.cdb is automatically rebuilt when this happens.
> You need to make sure vpopmail/bin/clearopensmtp is being run from cron
> every 30-60 minutes, otherwise these IP's will never expire.
Do I have to check this or has this already been done automatically?

Thanks for your kind help.

Reply via email to