And here is the log recordio produced:

First trying to send with Outlook Express 6:
==========================================================
40000000424e9e0d2550f4a4 8497 > 220 serv-domain.tld ESMTP
40000000424e9e0d2621584c 8497 < EHLO client-machine
40000000424e9e0d2622812c 8497 > 250-serv-domain.tld
40000000424e9e0d2622989c 8497 > 250-PIPELINING
40000000424e9e0d26229c84 8497 > 250-8BITMIME
40000000424e9e0d2622a06c 8497 > 250-SIZE 0
40000000424e9e0d2622a454 8497 > 250 AUTH LOGIN PLAIN CRAM-MD5
40000000424e9e0d2749e25c 8497 < AUTH LOGIN
40000000424e9e0d274ae814 8497 > 334 VXNlcm5hbWU6
40000000424e9e0d285ed4cc 8497 < dGVzdEBjaGVtdGVjby5ybw==
40000000424e9e0d2860057c 8497 > 334 UGFzc3dvcmQ6
40000000424e9e0d2972b9b4 8497 < NDU2
40000000424e9e1229d33cbc 8497 > 535 authentication failed (#5.7.1)
@40000000424e9e122aea2714 8497 < [EOF]
@40000000424e9e122aecbf24 8497 > [EOF]
=====================================================

Then I used Eudora 6.2:
=====================================================
40000000424ea2a73254068c 8621 > 220 serv-domain.tld ESMTP
40000000424ea2a7335ab88c 8621 < EHLO client-machine
40000000424ea2a7335bbe44 8621 > 250-serv-domain.tld
40000000424ea2a7335bfcc4 8621 > 250-PIPELINING
40000000424ea2a7335c2f8c 8621 > 250-8BITMIME
40000000424ea2a7335c663c 8621 > 250-SIZE 0
40000000424ea2a7335c9cec 8621 > 250 AUTH LOGIN PLAIN CRAM-MD5
40000000424ea2a73468b1d4 8621 < AUTH CRAM-MD5
40000000424ea2a73469e284 8621 > 334 PDg2MjEuMTExMjQ0OTY5M0BjaGVtdGVjby5ybz4=
40000000424ea2a7356f63d4 8621 < dGVzdEBjaGVtdGVjby5ybyBmMDY4Y2FiZmNmZTBlYTYzYjViZWY5NmU3NTI5OWMwMw==
40000000424ea2ac35db9edc 8621 > 535 authentication failed (#5.7.1)
40000000424ea2ac36e7ea74 8621 < RSET
40000000424ea2ac36e8e474 8621 > 250 flushed
40000000424ea2ac37ea23ec 8621 < MAIL FROM:<[EMAIL PROTECTED]>
40000000424ea2ac37eb4ccc 8621 > 250 ok
40000000424ea2ac38f26c2c 8621 < RCPT TO:<[EMAIL PROTECTED]>
40000000424ea2ac38f3ac7c 8621 > 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
40000000424ea2ac3a802494 8621 < QUIT
40000000424ea2ac3a83f13c 8621 > 221 serv-domain.tld
@40000000424ea2ac3a83f90c 8621 > [EOF]
=====================================================


As you can see, OE6 tried AUTH LOGIN, which didn't work, then closed connection.
Eudora tried first AUTH CRAM-MD5. After it failed, it tried to send the message without authentication, which of course failed.


Still, MySQL logs show no attempts to read the username/password from the database. Instead the same error message I mentioned before, is entered in maillog and sql database.

Clear passwords is enabled in vpopmail.




----- Original Message ----- From: "Bogdan Motoc - CRC" <[EMAIL PROTECTED]>
To: <vchkpw@inter7.com>
Sent: Friday, April 01, 2005 1:38 AM
Subject: Re: [vchkpw] authentication problem for qmail-smtp-auth



----- Original Message ----- From: "Tom Collins" <[EMAIL PROTECTED]>
To: <vchkpw@inter7.com>
Sent: Wednesday, March 30, 2005 9:59 PM
Subject: Re: [vchkpw] authentication problem for qmail-smtp-auth



On Mar 30, 2005, at 10:33 AM, Bogdan Motoc - CRC wrote:
So, what am I doing wrong? What have I missed? What else can I do to throw some light on this matter?
I apreciate any help you can give me.

One possibility:

If you don't have clear passwords enabled, and the user tries to use CRAM-MD5 for SMTP AUTH, their authentication will fail.

--
Tom Collins  -  [EMAIL PROTECTED]
QmailAdmin: http://qmailadmin.sf.net/  Vpopmail: http://vpopmail.sf.net/
You don't need a laptop to troubleshoot high-speed Internet: sniffter.com


Hmm... what auth method it is actually using is a good question. I'll try and log the smtp conversation (only recordio comes in mind at this point), and see exactly what's going on. Thank you for this ideea, and all the help.




Reply via email to