On Fri, 16 Dec 2005 16:03:07 +0000 (GMT), Drew Wells wrote:
> I have patched VpopMail 5.4.13 so that each user in a domain can have
> there E-Mail handled by there own set of .qmail files (in
> /var/vpopmail/domains/{domain}/{user}), this is a patch to
> 'int check_forward_deliver(char *dir)' in vdelivermail.c.

good idea

> Is this patch of any interest to anyone or is this meant to be done
> another way ?

since we're talking about revamping code, we should change the name of the files.

It's hard for some people to understand what qmail-local does and what vdelivermail does; calling files ".qmail" which are actually handled by vdelivermail is misleading.

As suggested by Charles Cazabon (archived at http://msgs.securepoint.com/cgi-bin/get/qmail0510/86/1/1/1/1/1.html), we should call these files .vpopmail and/or .vpopmail-user

this will clearly differentiate qmail-local and vdelivermail's responsibilities and will natively point newbies in the right direction.

both vpopmail and qmailadmin could be updated trivially, and a couple of lines of perl could upgrade everyone's vpopmail/domains directory tree. I'd be happy to write the upgrade script.

whether or not we decide to change the name of the files, we'll have to ask Antonio to update chkusr and checkuser before the release, or at least note the possible incompatibility with existing installations.


Jeremy Kister

Reply via email to