if this isn't the right place for questions help in such a propblem, please 
ignore and sorry. and also sorry for my bad english.

I like to run a mailserver on my openbsd 4.1. system. the services should be:
   - qmail (netqmail 1.0.5)
   - vpopmail (5.4.18)
   - courier-imap (4.1.2) with autentification via courier-authdaemon (0.59.1)
     against vpopmails vchkpw
   - webmailer

system staff:
   os.........: i386 openbsd 4.1
   cpu........: amd 64 (pc-style)

until now, qmail in conjunction with vpopmail works fine. the problem appears 
when building the courier-authdaemon. the module for authentication against 
vchkpw is not build. i miss some file like libauthvchkpw.so
the gmake output looks like:

--- snip ---
Compiling authvchkpw.c
authvchkpw.c: In function `auth_vchkpw_changepass':
authvchkpw.c:186: warning: passing arg 1 of `parse_email' discards qualifiers 
from pointer target type
Compiling authvchkpwlib.c
Compiling preauthvchkpw.c
preauthvchkpw.c: In function `auth_vchkpw_pre':
preauthvchkpw.c:67: warning: passing arg 1 of `parse_email' discards 
qualifiers from pointer target type
preauthvchkpw.c:141: warning: passing arg 3 of `vset_lastauth' discards 
qualifiers from pointer target type
Linking libauthvchkpw.la

*** Warning: linker path does not have real file for library -lvpopmail.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libvpopmail and none of the candidates passed a file format test
*** using a regex pattern. Last file checked: /home/vpopmail/lib/libvpopmail.a

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module libauthvchkpw.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
--- snip ---

after finish the authdaemon installation and start it, the log file looks like

--- snip ---
Oct 11 19:33:03 luna authdaemond: Installing libauthcustom
Oct 11 19:33:03 luna authdaemond: Installation complete: authcustom
Oct 11 19:33:03 luna authdaemond: Installing libauthvchkpw
Oct 11 19:33:03 luna authdaemond: File not found
--- snip ---

authdaemon was configured with:
   ./configure \
      --prefix=/usr/local/courier-authlib-0.59.1 \
      --with-authvchkpw \
      --with-mailuser=vpopmail \
vpopmail configure was:
   ./configure \
      --enable-roaming-users \
      --enable-tcpserver-file=/home/vpopmail/etc/tcp.smtp \
      --enable-tcprules-prog=/usr/local/bin/tcprules \
      --enable-relay-clear-minutes=60 \
      --enable-learn-passwords \
      --enable-qmail-ext \
      --enable-logging=v \

I'm not very firm with compiler/linker staff, so i need help. can and like 
anyone here on this list help me ? it would be very great.

Until now, i tried different versions of vpopmail and courier's authdaemon and 
combinations of them. i also installed the mailserver services on an x86_64 
openbsd 4.1 with exactly the same results.

I also tried to configure vpopmail with --enable-shared option - knowing that 
this flag isn't listed by configure --help -, in order to get a shared 
version of libvpopmail, but this doesn' work. I thought, this could also 
solve my problem.

best wishes

Reply via email to