i did rebuild with 5.4.26

now i get this from the server that is trying to send the mail:

smtp:
starting delivery 1865573: msg 487245 to remote [EMAIL PROTECTED]
delivery 1865573: failure: x.x.x.x_does_not_like_recipient./Remote_host_said:_511_sorry,_no_mailbox_here_by_that_name_(#5.1.1_-_chkuser)/Giving_up_on_x.x.x.x.


on the other end:

ls /home/vpopmail/domains/
foo.com

ls /home/vpopmail/domains/foo.com/
.qmail-default    .vpasswd.lock    caca        postmaster

ls -al /var/qmail/control/
total 20
drwxr-xr-x   2 root      qmail  512 Jul  6 10:31 .
drwxr-xr-x  12 vpopmail  qmail  512 May 27 01:09 ..
-rw-r--r--   1 root      qmail    3 May 26 20:47 concurrencyincoming
-rw-r--r--   1 root      qmail    3 May 26 23:03 concurrencylocal
-rw-r--r--   1 root      qmail   19 May 26 14:48 defaultdomain
-rw-r--r--   1 root      qmail   43 Jul  6 10:22 locals
-rw-------   1 root      qmail    0 Jul  5 12:38 locals.lock
-rw-r--r--   1 root      qmail   13 May 26 23:05 me
-rw-r--r--   1 root      qmail    7 May 26 23:05 plusdomain
-rw-r--r--   1 root      qmail   70 Jul  6 10:22 rcpthosts
-rw-------   1 root      qmail    0 Jul  5 12:38 rcpthosts.lock
-rw-r--r--   1 root      qmail   54 Jul  6 10:22 virtualdomains
-rw-------   1 root      qmail    0 Jul  5 12:38 virtualdomains.lock

# cat rcpthosts
localhost
foo.com

# cat virtualdomains
foo.com:foo.com


foo of course is not  the real domain...

connection to mysql is fine cause it does create the accounts. but that shouldn't matter for qmail anyway....

i did restart the qmail a few times and also rebooted the machine it self...

what's next?


Rick Macdougall wrote:
Quey wrote:
Hi,

On 06/07/08 18:44:29, kalin m wrote:
sorry... i had to change mail accounts...

no. it never worked.

vpomail is compiled from source with:
$ ./configure --enable-clear-passwd --enable-valias --enable-auth-module=mysql --enable-domainquotas --disable-roaming-users

Firstly do not use domainquoatas, they never really worked, and in fact this option has been removed from current versions.



Enable MySQL logging and see if it tries to hit the database


i haven;t added anything to this installation. just trying to set it for the first time on this machine...

the tar i fot off the inter7 site is called vpopmail-5.4.2.tar.gz there is no (24|25|26)


yikes! thats like many many many years old! .. Please grab the latest stable version from inter7's web site before doing anything else..


The latest versions are on SourceForge now

http://sourceforge.net/projects/vpopmail/

Regards,

Rick




!DSPAM:487104c532358903418869!

Reply via email to