It would be helpful if you could provide some more information. Did you have to manually start the Cygwin SSHD service while logged in as another user? Did it display a credentials error when you first tried to start it? If so, what username is the service configured to use when the VM comes up?

Nothing in the code should delete the root account. It would be helpful to know what accounts are listed when you run "net user"?


Kiran N wrote:
Hello all,

I have my Windows 2003 image configured with cygwin.There is a root account
and a password has been set for that.
I even updated the vcld.conf file with the password.
When I make a reservation, the vguest(vcl01) machine starts but fails when
it tries to do an ssh on it..
I tried running  /usr/bin/ssh -i /etc/vcl/vcl.key  -l root -p 22 -x vcl01
'uname -s' 2>&1 from command line says Host key authentication failed.
When I start the cygwin on that vmguest machine, I saw that there is no root
account so I infer thats why the above ssh fails..
Do I need to add root account again on every vmguest machine?

Please help!!

A part of the log file is below.
2010-04-14 12:41:28|20587|34:34|reload||executing
SSH command on vcl01:
|20587|34:34|reload| /usr/bin/ssh -i /etc/vcl/vcl.key  -l root -p 22 -x
vcl01 'uname -s' 2>&1
2010-04-14 12:41:31|22231|vcld:main(165)|lastcheckin time updated for
management node 1: 2010-04-14 12:41:31
2010-04-14 12:41:36|22231|vcld:main(165)|lastcheckin time updated for
management node 1: 2010-04-14 12:41:36

|20587|34:34|reload| ---- WARNING ----
|20587|34:34|reload| 2010-04-14
1/3: failed to execute SSH command on vcl01: uname -s, exit status: 255, SSH
exits with the exit status of the remote command or with 255 if an error
occurred, output:
|20587|34:34|reload| ssh output (uname -s): Permission denied, please try
|20587|34:34|reload| ssh output (uname -s): Permission denied, please try
|20587|34:34|reload| ssh output (uname -s): Received disconnect from 2: Too many authentication failures for root
|20587|34:34|reload| ( 0), notify (line: 727)
|20587|34:34|reload| (-1), run_ssh_command (line: 6239)
|20587|34:34|reload| (-2), _sshd_status (line: 2745)
|20587|34:34|reload| (-3), load (line: 847)
|20587|34:34|reload| (-4), reload_image (line: 665)
|20587|34:34|reload| (-5), process (line: 266)
|20587|34:34|reload| (-6) vcld, make_new_child (line: 594)

Reply via email to