Hello Andy, Kiran-

The Watcher account (and some of the others listed I think) was a special
pre-created account on the image we were provided to use for our VCL
installation - we were given a Windows 2003 image with some baggage and
random things installed, and that's what we are trying to get working on
this install.

I thought that I had configured a new "root" user for that Windows image
and for cygwin and installed the proper scripts into the home space of the
root user of cygwin.  However, I must have missed a step or many steps or
all of them  ;)

Andy, perhaps you could detail the process of creating a new root user for
Windows and getting that root user properly configured in Cygwin?  When I
did it, I used tutorials found on Google and such to help out, but that
could be what messed things up (I'm still puzzled by other things not
existing now on the image though).  Maybe you have something from a
previous e-mail you can cut and paste for us so you don't have to spend a
lot of time typing that out.  And I know you're busy, so if you don't have
time Kiran and I will figure this out ourselves.

Thanks for your help!


Brian Copcea

---------------------------- Original Message ----------------------------
Subject: Re: Problem with ssh on the vmguest machine
From:    "Kiran N" <kiran.nellima...@gmail.com>
Date:    Fri, April 16, 2010 10:09 am
To:      vcl-dev@incubator.apache.org

I cant see any folder as VCL under the path C:\cygwin\home\root\
Are there any extra steps of install which I am missing.I followed this link
Please suggest!


On Fri, Apr 16, 2010 at 8:53 AM, Andy Kurth <andy_ku...@ncsu.edu> wrote:

> This is very odd.  Do you have any idea where the "watcher" name may have
> come from?
> The AutoAdminLogin registry keys are set by autologon_enable.cmd.  This is
> what causes root to automatically be logged on when an image is booted for
> the fist time.  Please take a look at the following file on your image:
> C:\cygwin\home\root\VCL\Scripts\autologon_enable.cmd
> What do you see for the following lines?
> set USERNAME=root
> set PASSWORD=<should match setting in vcld.conf>
> -Andy
> Kiran N wrote:
>> Thanks Andy!
>> I did have to manually start the cygwin SSHD service and I did not get any
>> credentials error when I started up. It logged me in as watcher(so its
>> configured to that I guess when vm starts up).
>> When I checked for root account couldnt find one in /home directory. Also
>> the /etc/passwd files are different when compared between vmhost win2003
>> machine and the new vmguest?(vcl01,which starts up when I make a
>> reservation).
>> Below are the list of accounts:
>> Administrator watcher kaharris maestro sshd cyg_server Guest mjohnston
>> SUPPORT_388945a0
>> hope this info helps.. !
>> Thanks!
>> kiran
>> On Thu, Apr 15, 2010 at 9:56 AM, Andy Kurth <andy_ku...@ncsu.edu> wrote:
>>  It would be helpful if you could provide some more information.  Did you
>>> have to manually start the Cygwin SSHD service while logged in as another
>>> user?  Did it display a credentials error when you first tried to start
>>> it?
>>>  If so, what username is the service configured to use when the VM comes
>>> up?
>>> Nothing in the code should delete the root account.  It would be helpful
>>> to
>>> know what accounts are listed when you run "net user"?
>>> Regards,
>>> Andy
>>> Kiran N wrote:
>>>  Hello all,
>>>> I have my Windows 2003 image configured with cygwin.There is a root
>>>> account
>>>> and a password has been set for that.
>>>> I even updated the vcld.conf file with the password.
>>>> When I make a reservation, the vguest(vcl01) machine starts but fails
>>>> when
>>>> it tries to do an ssh on it..
>>>> I tried running  /usr/bin/ssh -i /etc/vcl/vcl.key  -l root -p 22 -x
>>>> vcl01
>>>> 'uname -s' 2>&1 from command line says Host key authentication failed.
>>>> When I start the cygwin on that vmguest machine, I saw that there is no
>>>> root
>>>> account so I infer thats why the above ssh fails..
>>>> Do I need to add root account again on every vmguest machine?
>>>> Please help!!
>>>> A part of the log file is below.
>>>> 2010-04-14 12:41:28|20587|34:34|reload|utils.pm:
>>>> run_ssh_command(6167)|executing
>>>> SSH command on vcl01:
>>>> |20587|34:34|reload| /usr/bin/ssh -i /etc/vcl/vcl.key  -l root -p 22 -x
>>>> vcl01 'uname -s' 2>&1
>>>> 2010-04-14 12:41:31|22231|vcld:main(165)|lastcheckin time updated for
>>>> management node 1: 2010-04-14 12:41:31
>>>> 2010-04-14 12:41:36|22231|vcld:main(165)|lastcheckin time updated for
>>>> management node 1: 2010-04-14 12:41:36
>>>> |20587|34:34|reload| ---- WARNING ----
>>>> |20587|34:34|reload| 2010-04-14
>>>> 12:41:36|20587|34:34|reload|utils.pm:run_ssh_command(6239)|attempt
>>>> 1/3: failed to execute SSH command on vcl01: uname -s, exit status: 255,
>>>> SSH
>>>> exits with the exit status of the remote command or with 255 if an error
>>>> occurred, output:
>>>> |20587|34:34|reload| ssh output (uname -s): Permission denied, please
>>>> try
>>>> again.
>>>> |20587|34:34|reload| ssh output (uname -s): Permission denied, please
>>>> try
>>>> again.
>>>> |20587|34:34|reload| ssh output (uname -s): Received disconnect from
>>>> 2: Too many authentication failures for root
>>>> |20587|34:34|reload| ( 0) utils.pm, notify (line: 727)
>>>> |20587|34:34|reload| (-1) utils.pm, run_ssh_command (line: 6239)
>>>> |20587|34:34|reload| (-2) utils.pm, _sshd_status (line: 2745)
>>>> |20587|34:34|reload| (-3) vmware.pm, load (line: 847)
>>>> |20587|34:34|reload| (-4) new.pm, reload_image (line: 665)
>>>> |20587|34:34|reload| (-5) new.pm, process (line: 266)
>>>> |20587|34:34|reload| (-6) vcld, make_new_child (line: 594)
> --
> Andy Kurth
> Virtual Computing Lab
> Office of Information Technology
> North Carolina State University
> andy_ku...@ncsu.edu
> 919.513.4090


Reply via email to