On Thu, Dec 18, 2008 at 11:20 PM, Timothy D. Lenz <tl...@vorgon.com> wrote:

>  I started switching to raid but ran into problems with lack of info. 3
> 500gb sata drives with 3 partitions each. The first 2 are mirrored with 1
> spare. That was to be for all the boot abd program files. The second was to
> be swap and the third which is raid 5 is storage for recordings. I have the
> recordings in use, but ran into some confusion about setting up the boot
> stuff. I don't recall the exact problem, but when installing the stuff for
> raid it did some kind of update, but only to the original kernal which is
> still there, not to the custom built which is being used. Some the messages
> pointed to things relating to using a ram disk during boot which is not
> suposed to be needed when just mirroring the boot area.
> I was going to also use LVM on the raid 5 part but ext3 wasn't well
> supported and the other file systems didn't have the full jernaling or
> something and I also want to set up samba and use some of that space for
> backing up my windows computer.
What distro did you tried to use?
I've tried Ubuntu about a year ago, but it didn't support any RAID nor LVM
configurations in installation stage, so I went back to Fedora, which has
all those options.

Configuration is very easily done. The only tricky part is that you have to
type some commands manually in fdisk to install MBR on both disks if you
want to boot from RAID-1 setup.
All the info is available on the net.

By the way, my swap is also on LVM/RAID-5.

I just don't know how to get rid from the node corruptions.
I start suspecting my hardware. Run memory tests many times, but no
conclusion so far.

> ----- Original Message -----
> *From:* Alex Betis <alex.be...@gmail.com>
> *To:* vdr@linuxtv.org
> *Sent:* Thursday, December 18, 2008 12:51 PM
> *Subject:* [vdr] Soft RAID-5 + LVM file system corruption
> Hello all,
> A system question, not so VDR related, but I hope someone in the list use
> the same configuration.
> From time to time my system won't boot since ext3 file system got corrupted
> and asks me to log in as root and run fsck manually. No bad blocks are
> found, just incorrectly stored nodes that are always fixed.
> I have 3 320GByte SATA disks partitioned to several large partitions, those
> partitions are configured to software RAID-5 between disks and on those
> RAID-5 partitions there are 2 LVM volumes, one for system and another for
> storage.
> There are also 250 MByte partition on every disk, while 2 of them are
> configured to software RAID-1 and mapped to /boot.
> System LVM gets corrupted more often since its used more intensively.
> Does anybody here have the same configuration? Or any other software RAID-5
> configuration?
> Did anyone faced such problems? Maybe someone facing the same problem
> without RAIDs?
> Any help will be appreciated.
> I'm running on Fedora 10 with 2.6.27 kernel.
> I had the same problem with Fedora 8 as well.
> Thanks.
> Alex.
>  ------------------------------
> _______________________________________________
> vdr mailing list
> vdr@linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
> _______________________________________________
> vdr mailing list
> vdr@linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
vdr mailing list

Reply via email to