Btw, I'm not sure if I mentioned, but this is happening in VDR 1.6, and I belive Halim has it on 1.7? So it has been around for quite a while. I can try patches if needed, as it should be pretty straight forward applying them on Gentoo, but 1.6 would be prefered.

Yip - I've been experiencing this since 1.6, and kernels from 2.6.24 thru 2.6.33.

Have tried manipulating the kernel source (dvb_ca_en50221.c) and adding breaks to extend wait times between READ/WRITE transactions to the CAM (multiple 'msleep(1);' commands). Used to help with earlier kernels, but has no affect for the past 2 years.

As I've mentioned before, I don't know what else to try.

Here's the problems I have with my CAM decryptions

* intermittant CAM crash, going from 'Alphacrypt' to 'CAM Ready'
* intermittant CAM lock out. Can't access CAM menu, but CAM still displays 'Alphacrypt'

Both respond to reset (or multiple, up to 10 resets) and CAM comes back.

My system has 2 identical CAMs. Problem only affects one at a time, but does affect both.

Also occurs in CAM versions 3.09 thru 3.16 (tried upgrading/downgrading).

vdr mailing list

Reply via email to