On 29.02.2012 12:22, Heikki Manninen wrote:
On 29.2.2012, at 13.18, Klaus Schmidinger wrote:

On 29.02.2012 12:13, Heikki Manninen wrote:
I have a number of different Conax CAM modules from different manufacturers and all of them 
disappear from VDR after a couple of days running. Hitting CAM reset on the CI menu will bring it 
back "online". Naturally all Conax channel recordings will fail silently as a result of 
this until the CAM has been brought back up. Switching to an encrypted channel just gives the 
standard "channel not available" message.

This happens (for me) with Satelco DVB-C card with Satelco CI. From what I 
understand, this seems to be a common problem though I'm not sure whether it is 
limited to Satelco devices only.

Would it be possible to force CAM reset on all CI slots when VDR is trying to 
start recording non-FTA channel?

Wouldn't it be better to fix the actual problem and prevent
the CAM from "disappearing"?

Of course as always. But we don't live in a perfect world ;)

I'm not too happy about the idea to start testing different DVB card/CI combos 
on my own expense to find one that works. Especially nowadays when finding 
non-USB/Linux supported tuners for cable reception is next to impossible.

I wasn't suggesting that you get some new hardware.
What I meant was to fix the driver, which I would assume is
causing the problems.

Of course, there might as well be a problem in VDR's own CAM
handling code. However, I've looked through that several times
and didn't find anything that looks fishy. But if somebody
can point out a bug in there, I'd be happy to accept a fix.

Klaus

_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to