On 05/08/2013 11:04 AM, Yaniv Bronheim wrote:
Hey,
Sorry for the delay,  all morning I've been working to verify again the package 
and upload new version that fits the changes we did for vdsm-python-cpopen.
We tried that until this package will be accepted to fedora, we'll make it as 
part of vdsm's rpms (http://gerrit.ovirt.org/#/c/13685/).

I ran rpmlint, koji build, and rpmbuild verification on the spec and source 
file,  all looks fine.
Please tell me if i need to run more tests before nudge you... (upload new spec 
and srpm https://bugzilla.redhat.com/show_bug.cgi?id=903246)
fedora-review gave these issues:
Issues:
=======
- Permissions on files are set properly.
  Note: See rpmlint output
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#FilePermissions
- Package does not contain duplicates in %files.
  Note: warning: File listed twice: /usr/lib64/python2.7/site-
packages/cpopen.so
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DuplicateFiles

You can ignore the first permissions related issue because that's a FP. Not sure why however this is wrong. 755 is perfectly ok for .so files

The second however needs to be addressed. You put there cpopen.so in the %files section twice. One time with attr and one time without. Remove the one without as this is a duplicate.

Thanks!
And thanks Dan for pushing it forward..

----- Original Message -----
From: "Ofer Schreiber" <oschr...@redhat.com>
To: "Dan Kenigsberg" <dan...@redhat.com>
Cc: "VDSM Project Development" <vdsm-devel@lists.fedorahosted.org>
Sent: Tuesday, May 7, 2013 8:04:55 AM
Subject: Re: [vdsm] sync meeting minutes

Sure, I can help.
I'll do it tomorrow when I'll arrive to the office.
(I haven't looked into the package itself, please make sure that it follows
all fedora guidelines, and that you have an official tarball published
somewhere, it will save some time)


ב-7 May 2013, בשעה 07:54, Dan Kenigsberg < dan...@redhat.com > כתב/ה:




On Mon, May 06, 2013 at 08:12:50PM -0400, Antoni Segura Puimedon wrote:


VDSM sync meeting May 6th 13:30 UTC








Federico says that he can't see anything pending for 3.2. Tomorrow 3.2.2 will


be released. If anybody has anything pending push and ping Federico today.





Storage is working on completing the feature pages, after that they will link


them in the oVirt release management page.


http://wiki.ovirt.org/OVirt_3.3_release-management


Dan suggests to link the feature pages in their incomplete state to get more


feedback.





Yaniv states features for oVirt-3.3 to be reported. Splitting supervdsm is


going to be one of them. Needs reviews.





Yaniv discussed the libvirt connection getting wrapper. We are still looking


for a better solution that doesn't involve a special cif instance.





Vinzenz hints Yaniv that for his cpopen that he needs to talk in fedora-devel


for the package to be reviewed there.

Ofer, maybe you too can help us out with the review of
Bug 903246 - Review Request: cpopen - Creates a subprocess in
simpler safer manner
and its acceptence into Fedora?






Infra has been working on improving vdsm utils for out of process execution.





The git master breakage from Mark Wu's patch was reverted and Giuseppe


Vallarelli has made a unit test for preventing future patches from breaking


master by importing vdsm/ modules from lib/vdsm.





Vinzenz to ask on the list about the jsonrpc model.





Libvirtvm.py and vm.py to be verified by Vinzenz and QE to be thoroughly
tested


this week.





Vinzenz points out that vdsClient is completely out of sync with the schema.


Dan mentions that Zhou Zheng Sheng has probably had some success with that.
To


be presented in the Shangai workshop.





Adam has automatically generated bindings that need review and should be
given


a push. Also vdsm schema verification has some work already done that should
be


resumed.





We should put effort in bringing up possible changes/inconsistencies in the


schema relative to the way the api is evolving.





Toni to copy the agenda of the workshop in the mailing list. (DONE)

Thanks!

_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel

_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel


--
Regards,

Vinzenz Feenstra | Senior Software Engineer
RedHat Engineering Virtualization R & D
Phone: +420 532 294 625
IRC: vfeenstr or evilissimo

Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Permissions on files are set properly.
  Note: See rpmlint output
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#FilePermissions
- Package does not contain duplicates in %files.
  Note: warning: File listed twice: /usr/lib64/python2.7/site-
  packages/cpopen.so
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DuplicateFiles


===== MUST items =====

C/C++:
[ ]: Package does not contain kernel modules.
[ ]: Package contains no static executables.
[ ]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[ ]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[ ]: %build honors applicable compiler flags or justifies otherwise.
[ ]: Package contains no bundled libraries without FPC exception.
[ ]: Changelog in prescribed format.
[ ]: Sources contain only permissible code or content.
[ ]: Package contains desktop file if it is a GUI application.
[ ]: Development files must be in a -devel package
[ ]: Package requires other packages for directories it uses.
[ ]: Package uses nothing in %doc for runtime.
[ ]: Package is not known to require ExcludeArch.
[ ]: Package complies to the Packaging Guidelines
[ ]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[ ]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL (v2 or later)", "Unknown or generated". 2 files have unknown
     license. Detailed output of licensecheck in /home/vfeenstra/903246
     -python-cpopen/licensecheck.txt
[ ]: Package consistently uses macro is (instead of hard-coded directory
     names).
[ ]: Package is named according to the Package Naming Guidelines.
[ ]: Package does not generate any conflict.
[ ]: Package obeys FHS, except libexecdir and /usr/target.
[ ]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[ ]: Package must own all directories that it creates.
[ ]: Package does not own files or directories owned by other packages.
[ ]: Requires correct, justified where necessary.
[ ]: Spec file is legible and written in American English.
[ ]: Package contains systemd file(s) if in need.
[ ]: Useful -debuginfo package or justification otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

Python:
[ ]: Python eggs must not download any dependencies during the build process.
[ ]: A package which is used by another package via an egg interface should
     provide egg info.
[ ]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[ ]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[ ]: Final provides and requires are sane (see attachments).
[ ]: Package functions as described.
[ ]: Latest version is packaged.
[ ]: Package does not include license text files separate from upstream.
[ ]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: python-cpopen-1.2.2-1.fc19.x86_64.rpm
python-cpopen.x86_64: W: incoherent-version-in-changelog 1.2.2 ['1.2.2-1.fc19', 
'1.2.2-1']
python-cpopen.x86_64: W: private-shared-object-provides 
/usr/lib64/python2.7/site-packages/cpopen.so cpopen.so()(64bit)
python-cpopen.x86_64: W: no-documentation
1 packages and 0 specfiles checked; 0 errors, 3 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint python-cpopen
python-cpopen.x86_64: W: incoherent-version-in-changelog 1.2 ['1.2-1.fc19', 
'1.2-1']
python-cpopen.x86_64: W: private-shared-object-provides 
/usr/lib64/python2.7/site-packages/cpopen-createprocess.so 
cpopen-createprocess.so()(64bit)
python-cpopen.x86_64: W: no-documentation
python-cpopen.x86_64: E: non-standard-executable-perm 
/usr/lib64/python2.7/site-packages/cpopen-createprocess.so 0775L
1 packages and 0 specfiles checked; 1 errors, 3 warnings.
# echo 'rpmlint-done:'



Requires
--------
python-cpopen (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libpthread.so.0()(64bit)
    libpython2.7.so.1.0()(64bit)
    python(abi)
    rtld(GNU_HASH)



Provides
--------
python-cpopen:
    cpopen.so()(64bit)
    python-cpopen
    python-cpopen(x86-64)



Unversioned so-files
--------------------
python-cpopen: /usr/lib64/python2.7/site-packages/cpopen.so

MD5-sum check
-------------
http://pypi.python.org/packages/source/c/cpopen/cpopen-1.2.2.tar.gz :
  CHECKSUM(SHA256) this package     : 
c7efa993e20f71a65dcb0bd445ea431014bed2e89dd8ce74adf81f83ff4068ba
  CHECKSUM(SHA256) upstream package : 
c7efa993e20f71a65dcb0bd445ea431014bed2e89dd8ce74adf81f83ff4068ba


Generated by fedora-review 0.4.0 (660ce56) last change: 2013-01-29
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 903246
_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to