Shmuel Leib Melamud has posted comments on this change.

Change subject: storage: Add inplace virt-sparsify support

Patch Set 13:

(1 comment)
File vdsm/storage/sdm/api/

Line 22: 
Line 23: from vdsm import virtsparsify
Line 24: from import guarded
Line 25: 
Line 26: from .copy_data import CopyDataDivEndpoint
> Importing from another verb is ugly. Since CopyDataDivEndpoint is reusable,
I've asked Adam in e-mail about this:

Me: It will not look good to import from So, 
we need to move CopyDataDIVEndpoint to some common place. What place should it 

Adam: For your first patch could you just try and do:

from copy_data import CopyDataDIVEndpoint

I want to keep the same names as in the schema for clarity. Later on, we can 
move the implementation of CopyDataDIVEndpoint out to a common module if 
necessary but I don't want to delay your verb for this.  We are simultaneously 
making improvements to CopyDataDIVEndpoint (locking, etc) and it will be easier 
to continue development in its current location for now.
Line 27: 
Line 28: from . import base
Line 29: 
Line 30: 

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: I6ac2bb1fbd2acbe0fc47694d17313c6ccd01a227
Gerrit-PatchSet: 13
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Shmuel Leib Melamud <>
Gerrit-Reviewer: Adam Litke <>
Gerrit-Reviewer: Allon Mureinik <>
Gerrit-Reviewer: Francesco Romani <>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Maor Lipchuk <>
Gerrit-Reviewer: Nir Soffer <>
Gerrit-Reviewer: Piotr Kliczewski <>
Gerrit-Reviewer: Shahar Havivi <>
Gerrit-Reviewer: Shmuel Leib Melamud <>
Gerrit-Reviewer: Shmuel Melamud <>
Gerrit-Reviewer: Yaniv Kaul <>
Gerrit-Reviewer: gerrit-hooks <>
Gerrit-HasComments: Yes
vdsm-patches mailing list --
To unsubscribe send an email to

Reply via email to