On 07/13/2009 06:15 AM, Greg Sutcliffe wrote:
> Hi guys,
> Got my very first GPS (eTrex Venture HC) last week, and as a Linux-only
> type of person, I've been investigating ways to get up-and-running with
> it. Discovered Viking pretty quickly, and I have to say, I'm impressed!
> The only other decent app seems to be QlandKarteGT, and it's
> documentation is non-existant, whereas Viking worked out-of-the-box for
> me, so good work devs. I've got Track/Waypoint upload/download working
> fine, so my GPS is useable for going walking now.
> Currently my question is regarding the map display in Viking. I've seen
> very nice screenshots involving pretty detailed contour maps, with
> shading of gradient and all sorts. However, I suspect these are taken
> from Google, which (reading the list) I understand has been removed from
> Viking. I've got all 4 OSM map tilings working fine, but the others (Terra*,
> BlueMarble, etc) seem to display nothing.
I'm still using an older version (svn revision 740 it looks like), and I
checked and the Terra server topos still work well. You have to change
to UTM mode for viewing, but it told me I needed to (At one point you
just had to know).

There are no restrictions on the USGS images that are downloaded from
this site.
Per http://terraserver-usa.com/About/AboutFaq.htm#DownloadRestrictions:
"The images from the U.S. Geological Survey, and are freely available
for you to download, use and re-distribute. The TerraServer team and the
USGS appreciate credit for their work on this project by displaying the
message "Image courtesy of the USGS."

Apparently the satellite imagery they used to have is no longer
available. The topos are still nice though (if you're in the US or
planning a trip over here.)

I should test Guilhem's latest version and see how that works.

> Finally, as a longtime Linux admin, occaisonal doc-writer, and wannabe
> developer, if there's anything I can usefully do to help out, give me a
> shout.
Unfortunately haven't been paying enough attention to know what
contributions need to be made.  It sounds like you've tested the
Terraserver Topos. Make sure you're in UTM  mode, and no less than 2mpp 
(meters per pixel ). If it still doesn't work then maybe this is
something you or I could try to dig into. (I know how to create memory
leaks in C - pretty easy :-)  )


Enter the BlackBerry Developer Challenge  
This is your chance to win up to $100,000 in prizes! For a limited time, 
vendors submitting new applications to BlackBerry App World(TM) will have
the opportunity to enter the BlackBerry Developer Challenge. See full prize  
details at: http://p.sf.net/sfu/Challenge
Viking-devel mailing list
Viking home page: http://viking.sf.net/

Reply via email to