Are you running a 64 bit version of ubuntu? The JSSH plugins  
available are 32-bit only, I believe:

You can compile your own extension:

If you're not sure, could you post the output of 'uname -a', please?

Thank you,


On 23 Apr 2009, at 03:17, emz452 wrote:

> Hi there,
> I have recently started working from home and have just finished
> setting up my rails development environment. I'm running into a
> problem with Watir when running some of my tests.
> This was all running smoothly on my PC at work, so it must be some
> setting or configuration problem on my home pc.
> I've seen this posted a couple of times in the forum, however I have
> tried all the recommended solutions and still can't seem to resolve
> it.
> The full error is:
> Unable to connect to machine : on port 9997. Make sure that
> JSSh is properly installed and Firefox is running with '-jssh' option
> (Watir::Exception::UnableToStartJSShException)
>      /home/emily/Documents/metis/vendor/plugins/watir-on-rails/lib/
> watir_on_rails.rb:35:in `open_browser'
>      ./features/support/watir.rb:331:in `initialize'
>      ./features/support/watir.rb:11:in `new'
>      ./features/support/watir.rb:11:in `initialize'
> A firefox browser does open up, but nothing further happens.
> My setup:
> I'm using Ubuntu 8.04 (Hardy) (dual boot with a windows pc)
> I have the gem firewatir 1.6.2 installed.
> I'm using Firefox 3 and have the JSSh 0.9 extension installed and
> enabled. (I made sure to select the Linux, Firefox 3 version from
> here: 
> http://wiki.openqa.org/display/WTR/FireWatir+Installation#FireWatirInstallation-2)InstalltheJSSHFirefoxExtension
> My firefox settings are -
> - New pages should be opened in a new window
> - Popups are not blocked
> I have tried uninstalling/re-installing the JSSh extension, disabling
> and re-enabling it and restarted firefox each time.
> If I launch firefox with -jssh and try to telnet:
> em...@emily-desktop:~$ firefox -jssh
> em...@emily-desktop:~$ telnet localhost 9997
> Trying
> telnet: Unable to connect to remote host: Connection refused
> em...@emily-desktop:~$
> When I run the unit tests it fails:
> em...@emily-desktop:/usr/lib/ruby/gems/1.8/gems/firewatir-1.6.2/
> unittests$ sudo ruby mozilla_all_tests.rb
> [sudo] password for emily:
> /usr/lib/ruby/gems/1.8/gems/firewatir-1.6.2/unittests/setup.rb:13:in
> `require': no such file to load -- watir (LoadError)
>       from /usr/lib/ruby/gems/1.8/gems/firewatir-1.6.2/unittests/setup.rb:
> 13
>       from mozilla_all_tests.rb:3:in `require'
>       from mozilla_all_tests.rb:3
> However I read that this happens with 1.6.2, so I'm not sure if this
> means anything. (I think I need to copy development files across?)
> If anyone has any suggestions of possible settings/config changes I
> could check, it would be greatly appreciated! I'm new to watir - so
> there may be something very obvious I've missed!
> Many thanks,
> Emily
> >

You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to