On Thu, 8 Feb 2018 14:45:06 +0200
Pekka Paalanen <ppaala...@gmail.com> wrote:

> On Wed, 7 Feb 2018 12:36:18 +0200
> Pekka Paalanen <ppaala...@gmail.com> wrote:
> 
> > On Wed, 7 Feb 2018 10:19:39 +0000
> > "Ucan, Emre (ADITG/ESB)" <eu...@de.adit-jv.com> wrote:
> >   
> > > Hi Pekka,
> > > 
> > > Yes, I know that it is an ABI breakage. But there is already another
> > > ABI breakage in compositor.h:
> > > fbf165f5e89576730eed4a7e3979100311c4f0f8 Users of ivi-shell has to
> > > recompile for weston 4.0 anyway.    
> > 
> > Ok. To be honest, I've lost track of what's ABI for you and what's not.
> > I'd appreciate a note in the commit message, so I see you've thought of
> > it. Anyway:
> > 
> > Reviewed-by: Pekka Paalanen <pekka.paala...@collabora.co.uk>  
> 
> Sorry, this patch alone triggers a distcheck failure for me.
> 
> [14:26:32.310] 
> weston_test_runner.run("surface_properties_changed_notification")
> [14:26:32.310] Assert failure in ../../tests/ivi_layout-test-plugin.c:905, 
> runner_func_surface_properties_changed_notification: 'ctx->user_flags == 0'
> [14:26:32.310] libwayland: error in client communication (pid 876)
> [14:26:32.408] 
> weston_test_runner.run("surface_bad_properties_changed_notification")
> [14:26:32.408] ivi_layout_surface_add_listener: invalid argument
> [14:26:32.408] ivi_layout_surface_add_listener: invalid argument
> [14:26:32.409] weston_test_runner.run("surface_on_many_layer")
> [14:26:32.409] Assert failure in ../../tests/ivi_layout-test-plugin.c:586, 
> runner_func_surface_on_many_layer: 'IVI_TEST_LAYER_COUNT == length'
> [14:26:32.409] Assert failure in ../../tests/ivi_layout-test-plugin.c:588, 
> runner_func_surface_on_many_layer: 'array[i] == ivilayers[i]'
> [14:26:32.409] Assert failure in ../../tests/ivi_layout-test-plugin.c:588, 
> runner_func_surface_on_many_layer: 'array[i] == ivilayers[i]'
> [14:26:32.409] Assert failure in ../../tests/ivi_layout-test-plugin.c:588, 
> runner_func_surface_on_many_layer: 'array[i] == ivilayers[i]'
> [14:26:32.409] Assert failure in ../../tests/ivi_layout-test-plugin.c:602, 
> runner_func_surface_on_many_layer: 'length == 0 && array == NULL'
> [14:26:32.409] libwayland: error in client communication (pid 1032)
> 
> 
> Oddly enough, 'make -j7 check' does not fail, but 'make -j7 distcheck'
> fails. Also 'make distcheck' does not fail, so it seems like a parallel
> testing problem. What baffles me is that I have not seen this failure
> before this patch, and both the failure and the successes seems to be
> very repeatable.
> 
> Can you reproduce this failure?

Trying to get to the bottom of this, I tried various things and nothing
made a difference until I wiped my out-of-tree builddir and configured
a new one the same as the old one. It doesn't fail anymore.

I'll see about landing the patches.


Thanks,
pq

Attachment: pgperxQMHVq5K.pgp
Description: OpenPGP digital signature

_______________________________________________
wayland-devel mailing list
wayland-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/wayland-devel

Reply via email to