On Monday, September 12, 2016 at 4:03:16 PM UTC+2, mwall wrote:
>
> On Sunday, September 11, 2016 at 11:44:15 AM UTC-4, Allan H wrote:
>>
>> Den 11-09-2016 kl. 16:33 skrev Allan: 
>>
>> > Well, without the resets, it doesn't seem to load here. 
>>
>> Follow-up: 
>>
>> I just tried to uncomment line 1562 to get the reset back, and the 
>> driver immediately started to work again 
>>
>
> well that is annoying.  apparently the reset is required on some systems, 
> but on other systems it causes the driver to fail. 
>
> allan, the logs you posted show bus= driver=, i.e., no value for bus or 
> driver, but that was with an error of undefined symbol.  
>
> when the driver is working, do you see values for bus and driver?
>
> it looks like we are in a version quagmire - some combinations of udev, 
> libusb, and pyusb work, but others do not.  and the usb reset seems to 
> trigger it.
>
> i think we now have a unit test:
>
> - which operating system and version?
> - which version of libusb?
> - which version of pyusb?
> - which version of udev?
> - which version of te923 driver (use 0.19 if possible)
>
> with reset un-commented:
> - what happens when you run the driver directly for --readings?
> - what happens when you run the driver directly for --records=5?
> - what happens when you run weewxd directly?
> - what happens when you run weewx as daemon?
> - what happens whey you run weewx as daemon at system startup?
>
> then the same again with reset commented.
>
> for each os/libusb/udev configuration it would also be nice to know 
> whether te923tool runs properly.
>
> m
>

On Monday, September 12, 2016 at 4:03:16 PM UTC+2, mwall wrote:
>
> On Sunday, September 11, 2016 at 11:44:15 AM UTC-4, Allan H wrote:
>>
>> Den 11-09-2016 kl. 16:33 skrev Allan: 
>>
>> > Well, without the resets, it doesn't seem to load here. 
>>
>> Follow-up: 
>>
>> I just tried to uncomment line 1562 to get the reset back, and the 
>> driver immediately started to work again 
>>
>
> well that is annoying.  apparently the reset is required on some systems, 
> but on other systems it causes the driver to fail. 
>
> allan, the logs you posted show bus= driver=, i.e., no value for bus or 
> driver, but that was with an error of undefined symbol.  
>
> when the driver is working, do you see values for bus and driver?
>
> it looks like we are in a version quagmire - some combinations of udev, 
> libusb, and pyusb work, but others do not.  and the usb reset seems to 
> trigger it.
>
> i think we now have a unit test:
>
> - which operating system and version?
> - which version of libusb?
> - which version of pyusb?
> - which version of udev?
> - which version of te923 driver (use 0.19 if possible)
>
> with reset un-commented:
> - what happens when you run the driver directly for --readings?
> - what happens when you run the driver directly for --records=5?
> - what happens when you run weewxd directly?
> - what happens when you run weewx as daemon?
> - what happens whey you run weewx as daemon at system startup?
>
> then the same again with reset commented.
>
> for each os/libusb/udev configuration it would also be nice to know 
> whether te923tool runs properly.
>
> m
>

Cheers,

Having the same issues. Tried doctoring the driver and -r, as daemon and 
not. System is as Pi2 with Raspbian, newest stable firmware and everything 
driver wise up-to-date. Weewx  version is 3.5. Here's part of my log:


Sep 22 07:36:22 raspberrypi weewx[4123]: engine: Using configuration file 
> /home/weewx/weewx.conf
> Sep 22 07:36:22 raspberrypi weewx[4123]: engine: Loading station type 
> TE923 (weewx.drivers.te923)
> Sep 22 07:36:22 raspberrypi weewx[4123]: te923: driver version is 0.19
> Sep 22 07:36:22 raspberrypi weewx[4123]: te923: polling interval is 10
> Sep 22 07:36:22 raspberrypi weewx[4123]: te923: observation map is 
> {'bat_1': 'outTempBatteryStatus', 'bat_3': 'extraBatteryStatus2', 'bat_2': 
> 'extraBatteryStatus1', 'bat_5': 'extraBatteryStatus4', 'bat_4': 
> 'extraBatteryStatus3', 'bat_wind': 'windBatteryStatus', 't_in': 'inTemp', 
> 'link_rain': 'rainLinkStatus', 't_5': 'extraTemp4', 'h_in': 'inHumidity', 
> 'h_4': 'extraHumid3', 'h_5': 'extraHumid4', 'h_2': 'extraHumid1', 'h_3': 
> 'extraHumid2', 'h_1': 'outHumidity', 't_2': 'extraTemp1', 'link_2': 
> 'extraLinkStatus1', 'link_uv': 'uvLinkStatus', 'link_wind': 
> 'windLinkStatus', 'uv': 'UV', 'bat_uv': 'uvBatteryStatus', 'link_5': 
> 'extraLinkStatus4', 'bat_rain': 'rainBatteryStatus', 'link_3': 
> 'extraLinkStatus2', 't_3': 'extraTemp2', 'link_1': 'outLinkStatus', 't_1': 
> 'outTemp', 't_4': 'extraTemp3', 'link_4': 'extraLinkStatus3'}
> Sep 22 07:36:22 raspberrypi weewx[4123]: te923: Found device on USB 
> bus=001 device=007
> Sep 22 07:36:23 raspberrypi kernel: [ 3630.838597] usb 1-1.4: reset 
> low-speed USB device number 7 using dwc_otg
> Sep 22 07:36:23 raspberrypi weewx[4123]: te923: Failed attempt 1 of 5 to 
> read data: error sending control message: Device or resource busy
> Sep 22 07:36:23 raspberrypi kernel: [ 3631.141743] hid-generic 
> 0003:1130:6801.000E: hiddev0,hidraw1: USB HID v1.10 Device [ ] on 
> usb-3f980000.usb-1.4/input0
> Sep 22 07:36:23 raspberrypi kernel: [ 3631.142215] usb 1-1.4: usbfs: 
> process 4123 (weewxd) did not claim interface 0 before use
> Sep 22 07:36:26 raspberrypi weewx[4123]: te923: Failed attempt 2 of 5 to 
> read data: error sending control message: Device or resource busy
> Sep 22 07:36:26 raspberrypi kernel: [ 3634.145927] usb 1-1.4: usbfs: 
> process 4123 (weewxd) did not claim interface 0 before use
> Sep 22 07:36:29 raspberrypi weewx[4123]: te923: Failed attempt 3 of 5 to 
> read data: error sending control message: Device or resource busy
> Sep 22 07:36:29 raspberrypi kernel: [ 3637.149716] usb 1-1.4: usbfs: 
> process 4123 (weewxd) did not claim interface 0 before use
> Sep 22 07:36:32 raspberrypi weewx[4123]: te923: Failed attempt 4 of 5 to 
> read data: error sending control message: Device or resource busy
> Sep 22 07:36:32 raspberrypi kernel: [ 3640.156489] usb 1-1.4: usbfs: 
> process 4123 (weewxd) did not claim interface 0 before use
> Sep 22 07:36:35 raspberrypi weewx[4123]: te923: Failed attempt 5 of 5 to 
> read data: error sending control message: Device or resource busy
> Sep 22 07:36:35 raspberrypi kernel: [ 3643.160304] usb 1-1.4: usbfs: 
> process 4123 (weewxd) did not claim interface 0 before use
> Sep 22 07:36:38 raspberrypi weewx[4123]: import of driver failed: Read 
> failed after 5 tries (<class 'weewx.RetriesExceeded'>)
> Sep 22 07:36:38 raspberrypi weewx[4123]: engine: Unable to load driver: 
> Read failed after 5 tries
> Sep 22 07:36:38 raspberrypi weewx[4123]:     ****  Waiting 60 seconds then 
> retrying...
>
 

-- 
You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to