Do I need to put the original engine.py back into the folder or do I leave
what you gave me in there?



On Sun, Oct 16, 2016 at 11:29 AM, Thomas Keffer <tkef...@gmail.com> wrote:

> Your value of archive_delay is set to 300 seconds. Change it to 15 seconds
> and all your problems will go away.
>
> archive_delay = 15
>
> -tk
>
> On Sun, Oct 16, 2016 at 11:18 AM, Tim Phillips <timaphill...@gmail.com>
> wrote:
>
>> New log attached after replacing the engine.py per instructions. Lots of
>> "syslog" files attached in this thread, so I've renamed this log with
>> appropriate changes- "new engine.py" in the file name
>>
>> Tim.
>>
>>
>> On Sunday, October 16, 2016 at 9:58:18 AM UTC-7, Tim Phillips wrote:
>>>
>>> Just followed your instructions and will post the new log file
>>> after it's had a chance to run a while as suggested.
>>>
>>> On Sunday, October 16, 2016 at 6:59:57 AM UTC-7, Tom Keffer wrote:
>>>>
>>>> On Sun, Oct 16, 2016 at 6:18 AM, mwall <mw...@users.sourceforge.net>
>>>> wrote:
>>>>
>>>>> On Sunday, October 16, 2016 at 8:19:38 AM UTC-4, Tom Keffer wrote:
>>>>>>
>>>>>> ​Me too.​ What do you think of my theory that the console is
>>>>>> (occasionally) waiting more than 5 minutes to emit a LOOP packet?
>>>>>>
>>>>>
>>>>> the log indicates that the driver is getting data regularly.  take a
>>>>> look at the entries between some of the 10 minute add records.
>>>>>
>>>>> there is a yield just before each "next read in X second".  when the
>>>>> data are stale, the yielded packet contains only dateTime, usUnits,
>>>>> channel, sensor_id, rssi, sensor_battery, but no weather data.
>>>>>
>>>>
>>>> ​That should be enough to give the engine a chance to break the loop.
>>>>
>>>> Tim: I have attached an instrumented version of
>>>> engine.py
>>>>  that should shed some light on this mystery. Please set your old
>>>> version of
>>>> engine.py
>>>> aside, and replace it with this one. Assuming you download this version
>>>> into
>>>> ~/Downloads
>>>> , the process would be:
>>>>
>>>> ​cd /usr/share/weewx​/weewx
>>>> mv engine.py engine.py.orig
>>>> cp ~/Downloads/engine.py engine.py
>>>>
>>>>
>>>> Make sure debug=1, then restart weewx, then send the log from the
>>>> restart, through the first couple of reports (should take about 20
>>>> minutes). The log will be big, so just attach it as a file.
>>>>
>>>> -tk
>>>>
>>>>
>>>>
>>>> ​
>>>>
>>>>
>>> --
>> You received this message because you are subscribed to the Google Groups
>> "weewx-user" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to weewx-user+unsubscr...@googlegroups.com.
>> For more options, visit https://groups.google.com/d/optout.
>>
>
> --
> You received this message because you are subscribed to a topic in the
> Google Groups "weewx-user" group.
> To unsubscribe from this topic, visit https://groups.google.com/d/
> topic/weewx-user/W8C-1CuFsik/unsubscribe.
> To unsubscribe from this group and all its topics, send an email to
> weewx-user+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.
>

-- 
You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to