On 27/03/2015 18:05, Jaggi, Manish wrote:
From: Julien Grall <julien.gr...@linaro.org>
Sent: Friday, March 27, 2015 7:11 PM
To: Jaggi, Manish; Xen Devel; prasun.kap...@cavium.com; Kumar, Vijaya; Ian 
Campbell; Stefano Stabellini
Subject: Re: [PATCH v1 3/3] xen/arm: smmu: Renaming struct iommu_domain *domain 
to, struct iommu_domain *iommu_domain

On 27/03/15 13:26, Jaggi, Manish wrote:
On 27/03/15 07:24, Manish Jaggi wrote:
It is good for code readability as there are many structures ending with
the name domain.
Also a code like this one is now easy to understand with the rename
old: dev_iommu_domain(dev) = domain;
new: dev_iommu_domain(dev) = iommu_domain;
[manish] Did u see this line

I don't care about the new vs old stuff. What I care is keeping the code
as close as possible to the Linux code.

[manish] then you are missing a point my friend. The line mentioned old is not 
at all intuitive and is confusing.

Please avoid familiarity... I'm not my friend and a such things will do the inverse effect you are trying to reach.

  I am not proposing a design change. All I am asking to add a prefix to 
iommu_domain pointers as was already done for smmu_domain pointers.

I didn't talk about design change but code modification. If you change the name of variables, it will require more work to backport a patch from Linux because the patch won't apply cleanly.

I've spent quite a lots of time to change as little as possible the Linux code and justify any change. You can see the different mail I had with Ian & Stefano for this purpose.

IHMO, changing the code just for your own comprehension is not a valid justification.

Regards,

--
Julien Grall

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to