On 09/21/2016 11:05 AM, Ian Jackson wrote:
> Boris Ostrovsky writes ("Re: [PATCH v4 10/21] acpi/hvmloader: Link ACPI
> object files directly"):
>> 2. ".tmp__" vs ".tmp": Because the temporary files are generated not in
>> tools/libacpi but in the directory of the libacpi user (such as libxl)
>> it is possible that a Makefile there might use ".tmp' for its own
>> purposes so I am trying here to minimize chances of a conflict. Maybe
>> even ".tmp_acpi"?
> Wait, the libxl makefiles are going to end up running iasl ?
Not directly. There is a new target in libxl's Makefile:
$(MAKE) -C $(ACPI_PATH) ACPI_BUILD_DIR=$(CURDIR)
(ACPI_PATH is tools/libacpi)
> If you end up making these files appear elsewhere then I think ".tmp"
> is fine if the first part of the filename is unique enough.
They are built in libxl directory, this is by design. If we were to
build them in tools/libacpi then we may collide with other components
(such as hvmloader) doing the build at the same time.
Keeping them in /tmp/`mktemp -d`, for example, does not quite work since
we can't easily clean this up in case of an interrupt. (I tried this in
an earlier version and it doesn't look good).
But the names are pretty unique (dsdt_<blah> or <ssdt_blah>).
Xen-devel mailing list