Kazuko O. wrote:
I updated JRE to "Java(TM) SE Runtime Environment 1.8.0_101", but
the issue was not fixed.


And I think I did not do specific sequence of actions after installing XXE.


This issue was not found for XXE v.6.7 with the same JRE.
This issue happens only for XXE v.7.1.

My co-worker says that font size calculation of XXE may have
problem under the Japanese environment.


I think you can reproduce the problem if you can try on the Japanese 
I attached a sample DITA file which contains Japanese characters, and the jpg 
which was captured when it was displayed in the XML source view.
But I am not sure whether this file helps to reproduce the problem.

Not when you don't use the Japanese environment. See attached screenshot. Works fine for me, even when I use ja-JP as my default locale.

I have no access to the Japanese environment. (In fact, I have no idea of what is the Japanese environment. Sorry. Is it Japanese Windows? Japanese Java?)

If you are 100% sure that it worked in XXE v.6.7, then I may try to find what has changed in the source view between 6.7 and 7.1 in terms of font management.

If I find something, I'll send you a patched xxe.jar for you to try it in your working environment.

Please confirm that you are 100% sure that it worked in XXE v.6.7.

One more question: are there similar problems in the styled view or in the tree view? Or it is just the source view?

XMLmind XML Editor Support List

Reply via email to