And lots of thanks for the great re-write work! I've built the driver, the 
firmware from yesterday's snapshots for an embedded ppc system running 
Sarge - and it worked!

Some details - in my setup I connect unencrypted to an AP, get the 
configuration over DHCP, and then run openvpn on the top. Everything 
worked, but I had to set up interfaces manually - automating the process 
with /etc/network/interfaces didn't work yet. I'll look further.

The working version for the original zd1211 ath.cx looked like this:

auto wlan0

mapping hotplug
        script grep
        map wlan0

iface wlan0 inet dhcp
        wireless_essid ******
        wireless_mode manage
        up iwconfig wlan0 essid "******"
        up openvpn --config /etc/openvpn/client.conf.ovpn
        pre-down kill `pidof openvpn`
        pre-down kill `ps ax | grep "[d]hclient.*wlan0" | cut -b-6`

(yes, I did replace wlan0 with eth1:-))

Guennadi Liakhovetski

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to