Ulrich Kunitz wrote:
> On 06-06-01 19:35 [EMAIL PROTECTED] wrote:
> 
> 
>>Hi!
>>I tested the following adapter with the rw driver:
>>
>>Brand: Fiberline WL-430U
>>usb ID: 1582:6003
>>chip ID string: zd1211b chip 1582:6003 v4810 full 00-11-f6 AL2230_RF pa0 g--
>>FCC ID:RU5AWG02U
>>
>>- loading of the module seems to besuccessfull, no warnings or errors.
>>- "iwlist eth1 scanning" shows available APs
>>- configuring with iwconfig essid/enc seems successfull, "iwconfig eth1" 
>>shows desired configuration and link quality.
>>
>>Problem:
>>- dhclient eth0 does not work:
>>DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
>>receive_packet failed on eth1: Network is down
>>
>>then i did "ifconfig eth1 up", but still the same error with dhclient.
>>So there is no network transfer possible.
>>
>>I also tested the eth1 device with wpa_supplicant with WPA/TKIP and WEP 64bit 
>>secured APs. In any cases it was not possible to associate with the AP.
>>
>>with the r77 version wep and wpa works with this device.
>>
>>Greetings,
>>Henning
> 
> 
> Henning,
> 
> could you please send us an output of iwconfig eth1 and ifconfig
> eth1  when you start dhclient and the Softmac output from
> /var/log/kern.log.
> 
> Remember to set the interface in managed mode:
> ifconfig eth1 up
> iwconfig eth1 mode managed
> 
> Regards,
> 
> Uli
> 
> 

Hi,
I did more tests with the device. I did set it to mode managed after 
bringing it up.

dmesg output after plugging in the device (there was no softmac output 
in kern.log):

usb 1-2: new full speed USB device using uhci_hcd and address 6
usb 1-2: configuration #1 chosen from 1 choice
zd1211rw 1-2:1.0: firmware version 4721
zd1211rw 1-2:1.0: zd1211b chip 1582:6003 v4810 full 00-11-f6 AL2230_RF 
pa0 g--
zd1211rw 1-2:1.0: eth1
ADDRCONF(NETDEV_UP): eth1: link is not ready
SoftMAC: Open Authentication completed with 00:0f:b5:b6:70:58
SoftMAC: Authentication response received from 00:0f:b5:b6:70:58 but no 
queue item exists.


while "wpa_supplicant -c/etc/wpa_supplicant.conf -Dwext -ieth1" prints 
after plugging in the device:

Trying to associate with 00:0f:b5:b6:70:58 (SSID='GanixNet2' freq=0 MHz)
Authentication with 00:00:00:00:00:00 timed out.
Trying to associate with 00:0f:b5:b6:70:58 (SSID='GanixNet2' freq=0 MHz)
Authentication with 00:00:00:00:00:00 timed out.
Trying to associate with 00:0f:b5:b6:70:58 (SSID='GanixNet2' freq=0 MHz)
Authentication with 00:00:00:00:00:00 timed out.
Trying to associate with 00:0f:b5:b6:70:58 (SSID='GanixNet2' freq=0 MHz)
Authentication with 00:00:00:00:00:00 timed out.
Trying to associate with 00:0f:b5:b6:70:58 (SSID='GanixNet2' freq=0 MHz)
Authentication with 00:00:00:00:00:00 timed out.
[....]

after this, "iwconfig eth1" is:
eth1      802.11g zd1211  ESSID:"GanixNet2"
           Mode:Managed  Frequency:2.472 GHz  Access Point: 
00:0F:B5:B6:70:58
           Bit Rate=11 Mb/s
           Encryption key:off
           Link Quality=85/100  Signal level=68/100
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

and "ifconfig eth1" is:
eth1      Protokoll:Ethernet  Hardware Adresse 00:11:F6:7F:CB:67
           BROADCAST MULTICAST  MTU:1500  Metric:1
           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           Kollisionen:0 Sendewarteschlangenlänge:1000
           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

I hope this gives enough information,
        Henning


_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to