On Sun, Jul 16, 2006 at 02:50:46PM +0100, Daniel Drake wrote:
> Mattia Dongili wrote:
> >I'm trying out zd1211rw in mainline and I'm having some problems.
> >
> >As soon as I plug the dongle and udev loads the firmware the leds are
> >shutting down and I can't subsequently use the wi-fi lan.
> 
> We don't do anything with the LED yet, so thats normal.
> 
> Does the vendor driver work for you?

I just tried, I get the same error as with r80 (failed intr_urb):
[  186.648000] 
[  186.652000]  _____     ____    _    ____
[  186.656000] |__  /   _|  _ \  / \  / ___|
[  186.664000]   / / | | | | | |/ _ \ \___ \
[  186.668000]  / /| |_| | |_| / ___ \ ___) |
[  186.672000] /____\__, |____/_/   \_\____/
[  186.676000]      |___/
[  186.680000] zd1211 - version 2.14.0.0
[  186.688000] usbcore: registered new driver zd1211
[  196.748000] usb 1-1: new full speed USB device using uhci_hcd and address 2
[  196.920000] usb 1-1: configuration #1 chosen from 1 choice
[  196.928000] vendor_id = 6891
[  196.932000] product_id = a727
[  196.936000] USB 1.1 Host
[  196.940000] Release Ver = 4330
[  196.944000] zd1211:bulk out: wMaxPacketSize = 40
[  196.944000] zd1211:bulk in: wMaxPacketSize = 40
[  196.944000] zd1211:interrupt in: wMaxPacketSize = 40
[  196.944000] zd1211:interrupt in: int_interval = 1
[  196.944000] zd1211:bulk out: wMaxPacketSize = 40
[  196.944000] EEPORM Ver = 4330
[  196.964000] zd1211:USB Download Boot code success
[  196.964000] zd1211: failed intr_urb
[  196.972000] zd1211:USB ST Code = -22
[  196.972000] zd1211: probe of 1-1:1.0 failed with error -5


[  139.008000] usb 1-1: new full speed USB device using uhci_hcd and address 2
[  139.180000] usb 1-1: new device found, idVendor=6891, idProduct=a727
[  139.184000] usb 1-1: new device strings: Mfr=16, Product=32, SerialNumber=0
[  139.188000] usb 1-1: Product: 3CRUSB10075
[  139.192000] usb 1-1: Manufacturer: 3COM
[  139.196000] usb 1-1: configuration #1 chosen from 1 choice
[  139.304000] zd1211 - http://zd1211.ath.cx/ - r80
[  139.312000] Based on www.zydas.com.tw driver version 2.5.0.0
[  139.428000] usb 1-1: reset full speed USB device using uhci_hcd and address 2
[  139.584000] Release Ver = 4330
[  139.588000] zd1211:bulk out: wMaxPacketSize = 40
[  139.588000] zd1211:bulk in: wMaxPacketSize = 40
[  139.588000] zd1211:interrupt in: wMaxPacketSize = 40
[  139.588000] zd1211:interrupt in: int_interval = 1
[  139.588000] zd1211:bulk out: wMaxPacketSize = 40
[  139.588000] EEPORM Ver = 4330
[  139.608000] zd1211:USB Download Boot code success
[  139.612000] zd1211: failed intr_urb
[  139.616000] zd1211:USB ST Code = -22
[  139.616000] zd1211: probe of 1-1:1.0 failed with error -5
[  139.620000] usbcore: registered new driver zd1211

> Your problem sounds similar to one I sent to the list yesterday. I 
> thought this was some kind of device bug with frames encrypted by 
> software, however I seem to be unable to use it for even unencrypted 
> networks (I made a mistake in my earlier analysis). Perhaps you could 
> try connecting to an unencrypted network just on the off-chance.

yeah, it is! disabling WEP makes the card up and working.

> Do you have any other wireless devices you could put in monitor mode to 
> help debug the problem?

unforunately this is my only wlan device...

Thanks a lot.
-- 
mattia
:wq!


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to