Le mercredi 03 février 2010 à 23:53 +0100, Benoit PAPILLAULT a écrit :
> julien cubizolles a écrit :
> >
> What could be tried as a workaround is to comment the code that trigger 
> the disconnect and see what happens. The code is located in 
> net/mac80211/mlme.c : comment ieee80211_set_disassoc(sdata);

I tried, it didn't help. The connection still gets dropped but the
driver crashes...

I'm back to the stock driver from 2.6.31-18 in ubuntu (no backports
modules, no compat-wireless package) : it never disconnects. I managed
to fix the only problem (bitrate of 1Mb/s) by tweaking 
to set it to 48M by default. I can live with that. Maybe I'll look at
the differences in the disassociation code when I have the time.



The Planet: dedicated and managed hosting, cloud storage, colocation
Stay online with enterprise data centers and the best network in the business
Choose flexible plans and management services without long-term contracts
Personal 24x7 support from experience hosting pros just a phone call away.
Zd1211-devs mailing list - http://zd1211.wiki.sourceforge.net/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to