Patches are available to fix this so I would suggest that you
request them from MOS support.

This fix fell through the cracks and we tried really hard to
get it in the current Solaris 10 release but sometimes things
don't work in your favor. The patches are available though.

Relabeling disks on a live pool is not a recommended practice
so let's review other options but first some questions:

1. Is this a redundant pool?

2. Do you have an additional LUN (equivalent size) that you
could use as a spare?

What you could do is replace this existing LUN with a larger
LUN, if available. Then, reattach the original LUN and detach
the spare LUN but this depends on your pool configuration.

If requesting the patches is not possible and you don't have
a spare LUN, then please contact me directly. I might be able
to walk you through a more manual process.



On 07/25/12 09:49, Habony, Zsolt wrote:
        There is a feature of zfs (autoexpand, or zpool online -e ) that it can 
consume the increased LUN immediately and increase the zpool size.
That would be a very useful ( vital ) feature in enterprise environment.

Though when I tried to use it, it did not work.  LUN expanded and visible in 
format, but zpool did not increase.
I found a bug SUNBUG:6430818 (Solaris Does Not Automatically Handle an Increase 
in LUN Size)
Bad luck.

Patch exists: 148098 but _not_ part of recommended patch set.  Thus my fresh 
install Sol 10 U9 with latest patch set still has the problem.  ( Strange that 
this problem
  is not considered high impact ... )

It mentiones a workaround :   zpool export, "Re-label the LUN using format(1m) 
command.", zpool import

Can you pls. help in that, what does that re-label mean ?
(As I need to ask downtime for the zone now ... , would like to prepare for 
what I need to do )

I used format utility in thousands of times, for organizing partitions, though I have no 
idea how I would "relabel" a disk.
Also I did not use format to label the disks, I gave the LUN to zpool directly, 
I would not dare to touch or resize any partition with format utility, not 
knowing what zpool wants to see there.

Have you experienced such problem, and do you know how to increase zpool after 
a LUN increase ?

Thank you in advance,
Zsolt Habony

zfs-discuss mailing list
zfs-discuss mailing list

Reply via email to