> From: Jim Klimov [mailto:jimkli...@cos.ru]
> Well, on my system that I complained a lot about last year,
> I've had a physical pool, a zvol in it, shared and imported
> over iscsi on loopback (or sometimes initiated from another
> box), and another pool inside that zvol ultimately.

Ick.  And it worked?

> > These sorts of problems seem like they should be solvable by introducing
> some service manifest dependencies...  But there's no way to make it a
> generalization for the distribution as a whole (illumos/openindiana/oracle).
> It's just something that should be solvable on a case-by-case basis.

I started looking at that yesterday, and was surprised by how complex the 
dependency graph is.  Also, can't get graphviz to install or build, so I don't 
actually have a graph.

In any event, rather than changing the existing service dependencies, I decided 
to just make a new service, which would zpool import, and zpool export the 
pools that are on iscsi, before and after the iscsi initiator.

At present, the new service correctly mounts & dismounts the iscsi pool while 
I'm sitting there, but for some reason, it fails during reboot.  I ran out of 
time digging into it ... I'll look some more tomorrow.
zfs-discuss mailing list

Reply via email to