On Wed, Apr 27, 2005 at 05:05:56PM -0400, Tim Peters wrote:
> Neither did I, Paul -- I don't know ZopeUndo from a hole in the ground.  It
> _might_ have helped if you had added an entry to ZODB's news file recording
> that ZopeUndo.Prefix had changed.

Yeah, but I don't know ZODB's news file from shinola ;-)
I've never checked out ZODB; ZopeUndo appears in lib/python/ in a Zope 
sandbox, and I updated CHANGES.txt which was all I thought was needed.
It might have helped if I'd paid attention to the docstring at the top of
ZopeUndo/Prefix.py which does point out that it's released as part
of ZODB too... but again, I've never worked on ZODB proper and don't know
the policies for documenting changes to it.

Funny thing is, I've been running a Zope-2.7.6-b2 client against a
Zope-2.7.3 ZEO server since Monday and hadn't noticed any problems
yet ... I guess I hadn't tried to undo anything. Just now I 
checked and apparently manage_undoForm always says
"there are no transactions that can be undone."
I presume that's the problem you guys found.


Paul Winkler
For more information about ZODB, see the ZODB Wiki:

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to