Tim Peters wrote:
[Chris Withers]

The alias I suggested is purely to mirror that of the oid_repr function,
and I would include it directly above of below the oid_repr function
with bigger documentation clues for blind people like me ;-)

Does anyone have any non-pedantic reasons for not including this alias?

[Dieter Maurer]

The name is far less than optimal.

  How about something more informative such as "oid_to_hex"
  and "oid_from_hex"?

I don't want to see any renaming, or aliasing, until the docs (comments &
docstrings) are clear.  I expect that when the docs are clear, the current
perceived need for new names will go away.  Contrarily, so long as the docs
remain inadequate, adding new names would just give us additional poorly
documented function names.  ("What's oid_from_hex?  I always used p64 for
that."  "Really?  Let me look ... ah, OK, they're two names for the same
function."  "Eh?!  Why two names?"  "Beats me ... not sure what they do
either -- the docstring sucks"  "Par for the course, then." <0.5 wink>)

Tim, let this thread die. p64 is perfectly all right, it's been mentionned many times on his list, and any cursory search in the code reveals it.


Florent Guillaume, Nuxeo (Paris, France)   Director of R&D
+33 1 40 33 71 59   http://nuxeo.com   [EMAIL PROTECTED]
For more information about ZODB, see the ZODB Wiki:

ZODB-Dev mailing list  -  ZODB-Dev@zope.org

Reply via email to