Hi,

dbus does not run in a local zone.

But you may get around this issue by this workaround:

cp /var/lib/dbus/machine-id /zones/sunstudio12/root/var/lib/dbus/machine-id

(replace /zones/sunstudio12/root with the path to your zone).

This worked for me to get scite running in a zone; scite also crashes in 
a zone because of the not running dbus.

regards

Bernd


http://www.opensolaris.org/jive/forum.jspa?forumID=80
Edwin Goei wrote:
> I originally posted this to the desktop-discuss list: 
> http://www.opensolaris.org/jive/thread.jspa?threadID=54321. Any ideas?
>
> I'm trying to run a VNC server from blastwave in a Solaris zone. I got past 
> the /tmp/** permission problems. When I run vncserver, it looks like 
> gnome-session crashes because it cannot find dbus-daemon. I saw some postings 
> that dbus does not run in a local zone. Any ideas on workarounds? Output from 
> uname -a is:
>
> SunOS dev17 5.11 snv_70b sun4v sparc SUNW,SPARC-Enterprise-T2000
>  
>  
> This message posted from opensolaris.org
> _______________________________________________
> zones-discuss mailing list
> zones-discuss@opensolaris.org
>
>   


-- 
Bernd Schemmer, Frankfurt am Main, Germany
http://home.arcor.de/bnsmb/index.html

M s temprano que tarde el mundo cambiar .
                        Fidel Castro

_______________________________________________
zones-discuss mailing list
zones-discuss@opensolaris.org

Reply via email to