hey kevin,

this is a known issue that is being fixed.  (i thought the fix had
already been pushed to the public repo, but i guess it hasn't happened

there is a pretty straitforward workaround.  do a pkg image-update, boot
to the new image, and then your zone install should work.


On Thu, Jun 04, 2009 at 06:21:39PM -0700, Kevin Pan wrote:
> Hi,
> I have installed the latest OpenSolaris 2009.06 and tried to create a new 
> zone. I have tried both installations on my local machine as well as 
> launching a OpenSolaris 2009.06 instance on Amazon EC2. Both came up with 
> something like this:
> ---
> ad...@computer:/zones# zoneadm -z testspeed install
> A ZFS file system has been created for this zone.
>    Publisher: Using opensolaris.org (http://pkg.opensolaris.org/release/).
>        Image: Preparing at /zones/testspeed/root.
> Sanity Check: Looking for 'entire' incorporation.
> ERROR: Unable to locate the incorporation 
> 'ent...@0.5.11,5.11-0.111:20090514T145840Z' in the preferred publisher 
> 'opensolaris.org'.
> Use -P to supply a publisher which contains this package.
> ad...@computer:/zones#
> ---
> Does anyone has any idea why? How can I resolve this problem? Thanks!
> Kevin.
> --
> This message posted from opensolaris.org
> _______________________________________________
> zones-discuss mailing list
> zones-discuss@opensolaris.org
zones-discuss mailing list

Reply via email to