On 11/12/11 03:24 AM, Mike Gerdts wrote:
On Fri 11 Nov 2011 at 09:41AM, Ian Collins wrote:
On 11/11/11 09:20 AM, Mike Gerdts wrote:
On Fri 11 Nov 2011 at 08:41AM, Ian Collins wrote:
Solaris 11 Express with the latest updates from the support repo.

I'm getting an odd problem creating zones and I wanted to check the
package list:

Package State Update Phase                     45/45
Image State Update Phase                         2/2
    Installing: Additional Packages (output follows)
Creating Planpkg: 'SUNWbip' matches multiple packages

ERROR: failed to install package

I removed SUNWbip from /usr/lib/brand/ipkg/pkgcreatezone and the
zone installed OK.  I'll add the package in the zone later.

Someone should have a look at a proper fix!
I believe that it is already fixed in


I think (but do not know) that you should be able to fix the problem you
are seeing with:

# pkg update pkg://solaris/system/zones/brand/ipkg

Based on the dependencies in that package, it looks like that will also
update pkg:/package/pkg to 0.5.11- as well.
Odd, I had done a pkg update to get the latest bits, so

pfexec pkg update pkg://solaris/system/zones/brand/ipkg
No updates available for this image.

The problem occurred both before and after the update.

Oh well, I was only adding the zone to make sure the upgrade to
Solaris 11 worked OK on supported Express system!
That seems odd.  What do the following tell you?

pkg list -af system/zones/brand/ipkg
pkg update -v 

I was wrong in my comment, it turns out I had forgotten to reboot into the new BE. But as anyone who has tried it knows, the latest update creates an unbootable BE, so I had to work with the original.


zones-discuss mailing list

Reply via email to