Hi!

I have some trouble using five.localsitemanager in a buildout with Zope2 
2.12.dev. This is the error I get:

   Error: There is a version conflict.
   We already have: zope.location 3.5.3
   but Zope2 2.12.dev requires 'zope.location==3.5.2'.

The setup.py of five.localsitemanager specifies these dependencies:

       install_requires=[
         'setuptools',
         'zope.component >= 3.5.0',
         'zope.container',
         'zope.event',
         'zope.interface',
         'zope.location >= 3.5.0',
         'zope.site >= 3.6.0',
         'zope.traversing',
         'Acquisition',
         'Zope2',
         'ZODB3',
       ],

If I remove the dependencies that are also part of the Zope2 2.12.dev 
dependencies everything works fine:

       install_requires=[
         'setuptools',
         'Zope2 >= 2.12.dev',
       ],

Is that the right way to resolve that issue? Could it cause any trouble 
if I would check in that change?


Cheers,

        Yuppie

_______________________________________________
Zope-CMF maillist  -  Zope-CMF@lists.zope.org
http://mail.zope.org/mailman/listinfo/zope-cmf

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests

Reply via email to