Hanno Schlichting wrote:
> Wichert Akkerman wrote:
>> Previously yuppie wrote:
>>> I'd like to change install_requires to 'zope.component < 3.6dev' and
>>> make tests work with zope.component 3.5.1 and older versions.
>>> Any objections?
> I'd just remove the version number altogether. If this version works
> with a yet unreleased version or not is speculation.
> The recommendation for using the 2.0 version with Zope 2.12 is a KGS
> information and not a requirement in my view.
I doubt you can satisfy the requirements for five.localsitemanager 2.0
in a Zope version older than 2.12. That's why Zope2 >= 2.12.dev is
specified as dependency. I thought you were fine with that.
five.localsitemanager 1.x doesn't depend on eggified Zope versions, so
we need different ways to make recommendations.
That said, I don't care much about the solution for older packages.
Removing just the version number doesn't seem to make sense because no
other unrestricted dependencies are specified. But I'm not familiar with
the consequences for fake-egg based installations. So feel free to make
any changes you like.
Zope-CMF maillist - Zope-CMF@lists.zope.org
See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests