Charlie Clark wrote:
> Am 21.04.2010, 12:57 Uhr, schrieb Charlie Clark
>> Additionally I'd like to rename the view folder/@@edit.html to
>> folder/@@contents.html. I kept the view name to match the PythonScript
>> I think it is both misleading - you cannot "edit" the folder with this
>> view and it causes problems with classes derived from PortalFolder which
>> are contentish (a not unusual or unreasonable thing but which currently
>> forces a new name for an edit view or some hacking to have a dedicated
>> contents view). Apart from updating the profiles and, presumably, an
>> upgrade step I don't see any side-effects.
> aagh! wrong again!
> edit -> @@properties.html, folder_contents -> @@edit.html
I agree this is confusing. I think this would be better:
object/metadata -> @@properties.html, object/edit -> @@edit.html
and folder/folderContents -> @@edit.html of the parent
> Gets me every time! I can just about live with "edit" referring to the
> metadata view although this is different from all other content objects
> but I'd prefer folders not to have edit views unless dedicated ones exist.
> Do we need an edit view to conform with actions/object?
Well. 'folder_contents' *is* an edit view. If you add, move or delete
subobjects you *edit* the folder. Because besides metadata this is the
only thing you edit in plain folders, I chose this generic name for that
This is about dividing editing into different pages. You can edit
properties, subobjects and other content on the same page or on
I personally use just "object/edit -> @@edit.html" and a modified
@@edit.html that allows to edit Title and Description as well.
Zope-CMF maillist - Zope-CMF@zope.org
See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests