Am 21.04.2010, 15:14 Uhr, schrieb yuppie <y.2...@wcm-solutions.de>:
> I agree this is confusing. I think this would be better:
> object/metadata -> @@properties.html,
Agreement on this, at least.
> object/edit -> @@edit.html
> and folder/folderContents -> @@edit.html of the parent
It's the second line that gets me - it's not consistent to have "edit" on
the one hand and "folderContents" on the other referring to the *same*
thing. I would prefer:
object/edit -> @@contents.html
folder/folderContents -> @@contents.html
> Do we need an edit view to conform with actions/object?
> Well. 'folder_contents' *is* an edit view. If you add, move or delete
> subobjects you *edit* the folder. Because besides metadata this is the
> only thing you edit in plain folders, I chose this generic name for that
I agree with this technically I just don't think it corresponds to most
user expectation as in my objection above. My suggestion would essentially
leave things as they but invite a customised edit view for anyone so
inclined. And I also know that this is hair-splitting of the finest art.
But, over the last few years that I've been working with the CMF, I've
come to view it as an excellent reference for what you can do with Zope
without frying your brain.
> This is about dividing editing into different pages. You can edit
> properties, subobjects and other content on the same page or on
> different pages.
> I personally use just "object/edit -> @@edit.html" and a modified
> @@edit.html that allows to edit Title and Description as well.
This would still be possible, of course.
Clark Consulting & Research
Zope-CMF maillist - Zope-CMF@zope.org
See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests