I am not "using" any python. Basically, it is using
Zope2.6.4's python 2.1.3.  The ZPysopgDA or psycopg
1.0.12 is in the binaries format so I am not sure what
version of Python is used for compilation.

Any suggestions.

Thanks.


--- Charlie Clark <[EMAIL PROTECTED]> wrote:
> 
> On 2005-05-27 at 12:52:05 [+0200], Infor Gates
> <[EMAIL PROTECTED]> wrote:
> > Dear Zopists
> > 
> > I am looking for ZPyscopgDA that works with
> Postgresql
> > 8.0.3 on Windows. Can anyone point me to the URL?
> > 
> > I found an old version ZPyscopgDA ver 1.0.12 for
> > window binaries.  However, it does not work with
> > Postgresql 8.0.3. My Zope version is 2.6.4.
> > 
> > Error message:
> > psycopg.OperationalError
> > could not create socket: An address incompatible
> with
> > the requested protocol was used. (0x0000273F)
> 
> Strange: I've got psycopg running fine with
> PostgreSQL 8 for Windows. But 
> that is with Python 2.3. It's really the psycopg
> drivers that you need 
> rather than the DA itself. What version of Python
> are you running? You 
> should be able to compile your own version.
> Alternatively you can use our 
> mxODBCZopeDA with the pgODBC driver as this
> definitely works.
> 
> Charlie
> -- 
> Charlie Clark
> eGenix.com
> 
> Professional Python Services directly from the
> Source
>  >>> Python/Zope Consulting and Support ...       
> http://www.egenix.com/
>  >>> mxODBC.Zope.Database.Adapter ...            
> http://zope.egenix.com/
>  >>> mxODBC, mxDateTime, mxTextTools ...       
> http://python.egenix.com/
>
________________________________________________________________________
> 
> ::: Try mxODBC.Zope.DA for
> Windows,Linux,Solaris,FreeBSD for free ! ::::
> 


                
__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new Resources site
http://smallbusiness.yahoo.com/resources/
_______________________________________________
Zope-DB mailing list
Zope-DB@zope.org
http://mail.zope.org/mailman/listinfo/zope-db

Reply via email to