Hi Infor,

please post your replies to the list as well, so other can also help /
take advantage of this thread.

>Your best guest is correct (1st alternative).
>I had tried as suggested. However, it did not work.
>My best guess is that the psycopg binaries is compiled
>with PostgreSQL 7.x headers/lib for (cgywin). I am
>using PosgreSQL 8.0 for (native) windows. This is
>cause of it.
Yes, actually in the website I gave you there is a table, where the only
binaries for zope 2.6.4 you can download are the ones for python 2.1,
which were compiled for postgreSQL 7.3. So, you have to update your zope
to 2.7.x if you want to use binaries that work with postgreSQL 8. Now
I remmebered that was the version of zope I used.

But before installing psycopg you also need the egenix mx extensions:


The link is now is broken I don't know if they are going to fix it. To
install this binaries, you can follow the procedure I indicated in my
previous reply.

>Is there psycopg (with ZpsycopgDA) compiled with Zope
>2.6.3(python2.1.3)/PostgreSQL8.0 headers/lib or do I
>need to make one myself. If so, how I can do it? I do
>not have MSVC++ compiler but have download Bloodshed
I think there isn't such psycopg for the windows Zope binaries. The
problem is that what you need is Zope 2.6.4 compiled with a python that
has the psycopg module preinstalled on it. In fact, what you need to do

1) Build python 2.1.3 from source
2) Build the genix mx extenssions from source using the python you
3) Build postgresql from source??? -> I'm not sure if psycopg needs
   it, you have to check the readme and/or install files.
3) Build psycopg from source using the python of step 1
4) Build Zope 2.6.4 from source using the python you built.

Unfortunatelly, I haven't done this under windows, so, I can't help
you there. Anyway, the binaries worked for me once, but I haven't them
anymore and it was on zope 2.7, which uses python 2.3

Josef Meile

Zope-DB mailing list

Reply via email to