Hello everybody,

        I've looked through the mailing list archives and saw one
individual who had this problem but seemed to be able to fix it by
removing and then re-installing SiteAccess.  I haven't been that lucky.

        I have just freshly installed Zope 2.2.0 on a Red Hat Linux 6.2
machine.  The first thing I did after installing Zope was start it up to
verify that I can access it (http://localhost:8080/.)  Everything works
fine.  I then stop Zope and install SiteAccess by untaring in the Products
directory.  I restart Zope.  SiteAccess is listed in the products section.
        I then proceed to add a SiteRoot object in my / folder.  After
filling in the fields in the creation screen, I press create.  At that
point I get an error stating that the folder already has a SiteRoot object
(even though I am POSITIVE there wasn't one when I started.)  I press OK,
and the SiteRoot object is there in the folder.  However, when I access
the / folder with my browser, none of the URLs are modified as I expect
them to be.

        I have tried removing and re-installing SiteAccess, as well as
blowing away my Zope install and re-installing.  Neither has worked.

        Furthermore, when I go to delete the SiteRoot object from the
directory, I get the following errors:

2000-07-20T17:17:27 ERROR(200) Zope manage_beforeDelete() threw Traceback 
(innermost last):
  File /usr/local/EMtech-Zope/lib/python/OFS/ObjectManager.py, line 294, 
in _del Object
    (Object: ApplicationDefaultPermissions)
  File /usr/local/EMtech-Zope/lib/python/Products/SiteAccess/SiteRoot.py, 
line 4 5, in manage_beforeDelete
    (Object: SiteRoot) AttributeError: meta

        Can anybody help me with this?

-- 
Michael Monsen                   | Due to lack of interest,
[EMAIL PROTECTED]             |    next week has been cancelled.
http://www.xmission.com/~phydoux |


_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to