On Tue, 18 Jun 2002 11:20:21 -0400 "Jeremy Hylton" <[EMAIL PROTECTED]> wrote:

> >>>>> "AS" == Andrew Sydelko <[EMAIL PROTECTED]> writes:
>   AS> Trying Zope 2.6.0a1 and ZEO 2.0a1. The storage server seemed to
>   AS> come up fine, but when trying to start the ZEO client it pretty
>   AS> much sucked.
> It looks like you would have had the same problems without ZEO.  It
> would be helpful if you could try running Zope without ZEO, just with
> FileStorage. 

Hmm... The first time I copied the 3gig Data.fs over and tried to start
Zope a few times. After fiddling with the permissions of the var directory
it finally started, but the Data.fs was only 2MB!

So I copied it again. And once again, the 3gig Data.fs is blown away!
What am I doing wrong??? What are the permissions of the "var" folder
supposed to be? I'm starting Zope with:

python Zope/z2.py -w 8080 -F 8081 -W 8082 -u httpd 

>   AS> I really should include the log file it produced but it's quite
>   AS> long.  I put it up at
>   AS> http://eng.purdue.edu/people/sydelko/zope_2.6a1_log_1
>   AS> It ended up dying at the end, but that I think I can fix.
>   AS> I'd really like someone to clue me into why everything else
>   AS> complained.
> The errors in the log are all about failures to import specific
> modules.  (Let me know if I missed something else.)  
>     Failed to import class Splitter from module
>     Products.PluginIndexes.TextIndex.Splitter.ZopeSplitter
> When I import Products...ZopeSplitter, I see a module with a Splitter
> attribute bound to a function.

I don't understand what you're saying here. Do you mean it works
without complaining for you? In the past I have deleted all the
Products that were in the Products Control Panel to fix a similar bug.
Is that the case here as well?

> The other import problem I see is
>     Zope Could not import Products.HTMLDocument
> Is HTMLDocument a standard product or a 3rd party product?  I don't
> see one in my 2.6 checkout.  If it's 3rd part, then I expect it needs
> to be upgrade to work with 2.6.

HTMLDocument is a 3rd party product. Is there a document that says what
has changed enough since 2.5.1 that would break products? and how to fix them?

This is frustrating...


Zope-Dev maillist  -  [EMAIL PROTECTED]
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to