> what do you mean by "inserted into the form"?

Put there by the dtml-method in a dtml-var statement.

> That the response contains a single byte where you properties 
> contain character whose unicode value is greater than 127 ? 

Yes

> how have you checked this? if so, thats a bug.

In a Hex editor...

The character '' for instance is inserted as '0xE6' in the
returned HTML. 

> > Secondly, the type attribute of all inputfields contain an extra
> > ':utf8:' that we assumed is a server directive to interpret the
> > contents as UTF-8. This apperently what crashes when storing the
> > second time.
> 
> This is a directive to tell zope when you submit the form 
> that your browser will have encoded the form response using 
> utf-8. Browsers stupidly dont put this information anywhere 
> more suitable.

Yeah, we figured this would be similar to ':method'.

> What browser are you using? is it correctly using utf8 for 
> this page?  (for example, Mozilla has a View/Encoding menu 
> that can override server-supplied encoding information)

We have so far tried Opera 6, IE 6 and Mozilla 1.1.

> > lib/python/OFS/dtml/properties.dtml contains the following 
> > that seems to us to be debug code:
> >    <dtml-call "REQUEST.set('management_page_charset','UTF-8')">
> >    <dtml-var "u''">
> > and several ':utf8:' directives.
> >
> > When we removed those, it worked fine. Was this dtml-method 
> > merged in mistakenly
> 
> Those are supposed to be there.  The first inserts the 
> text/html;charset=utf-8  header into the management page.
> The second ensures that the dtml which computes this page 
> content returns a unicode object.
>
> If the dtml returns a unicode object, then ZPublisher looks 
> at the charset header to determine how to encode it.

This is DTML/ZOPE internal, right? I though the first two 
letters to signify endianness 'FFFE' or 'FEFF', tells you 
that this is UTF-8. The u'' string is not on the firs line.

> please put ib/python/OFS/dtml/properties.dtml back the way is 
> was originally, then send me 
> 
> 1. which browser you are using

I am using Opera 6.02, but we are seeing it on all browsers.

> 2. a export file containing one object that demonstrates the problem.

It is on every property page in the whole site, but see the attached 
.zexp of /standard_template.pt

> 3. a copy of the page obtained using wget or similar.  
> (please dont use your browsers 'save' feature because 
>  that sometimes performs transcoding)

I used wget...



 -- Arnar Lundesgaard

Attachment: standard_template.pt.zexp
Description: standard_template.pt.zexp

Attachment: manage_propertiesForm.1
Description: manage_propertiesForm.1

Reply via email to