Alexander Limi wrote:
Will Zope 2 ever run on Python 2.5, or is that postponed indefinitely?


It will run on Python 2.5 when somebody makes it run.

We see an increasing amount of users trying to use Zope 2 with their systems that have Python 2.5 as default.

Then I suggest you do something about it. Making it a sprint topic on one of the numerous Plone sprints would help, for instance.

As far as I can remember, Nikhil (our GSoC student) looked at making RestrictedPython work on Python 2.5. Somebody should review this. Moreover, there are lots C extension that -- last time I checked -- just failed to compile on Python 2.5. Though I'm sure most of these problems could be fixed by applying suggested replacements in the Python 2.5 release notes.


--
http://worldcookery.com -- Professional Zope documentation and training
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope )

Reply via email to