Hey,

is there any reason why my patch has been ignored so far? if there are
issues with it, please tell me so I can fix them ...

greetings,
 jonas

On 10/07/2009 Jonas Meurer wrote:
> Hello again,
> 
> On 07/07/2009 Andreas Jung wrote:
> > As Tres already pointed out: the *relevant* scripts are registered using
> > entry points afaik and will use the right Python interpreter.
> > 
> > Wrong references to old Python versions in
> > 
> > src/AccessControl/securitySuite/regressionSecurity.py
> > src/Products/ZCTextIndex/tests/mhindex.py
> > 
> > should be fixed but this only a cosmetic issue here.
> 
> and as I can see in svn, you already fixed both of them. thanks for
> that.
> 
> but what about all the scripts that still have python2.4 hardcoded as
> interpreter? if zope2.12 doesn't support python2.4, these should be
> fixed as well in my eyes.
> 
> here's a list of scripts that use hardcoded python2.4 interpreter:
> 
> src/Zope2/utilities/check_catalog.py
> src/Zope2/utilities/compilezpy.py
> src/Zope2/utilities/copyzopeskel.py
> src/Zope2/utilities/decompilezpy.py
> src/Zope2/utilities/load_site.py
> src/Zope2/utilities/mkzeoinstance.py
> src/Zope2/utilities/mkzopeinstance.py
> src/Zope2/utilities/requestprofiler.py
> src/Zope2/utilities/zpasswd.py
> 
> and one test has a python2.4 requirement in documentation:
> 
> src/ZPublisher/tests/generate_conflicts.py
> 
> see the attached patch to fix these remaining ones.
> 
> greetings,
>  jonas
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to