I have been successfully running for many months on Windows XP and Mac
OS X.  I cannot get the server to run on HP-UX, however.  I can build
and install o.k., but when I visit http://127.0.0.1:8080/ in the
browser, the process either hangs (built under python 2.3.5) or
terminates with a bus error (built under python 2.4.1 or 2.4.2).  In
any case, the (verbose) output from the runzope process looks like
this:

------
2005-10-03T17:34:31 WARNING ZODB.FileStorage Ignoring index for
/ford/et17112/u/cleonell/cusr/local/zopehome/var/Data.fs
------
2005-10-03T17:34:31 INFO PublisherHTTPServer zope.server.http (HTTP)
started.
        Hostname: et17112
        Port: 8080
------
2005-10-03T17:34:31 INFO PublisherFTPServer zope.server.ftp started.
        Hostname: et17112
        Port: 8021
------
2005-10-03T17:34:31 INFO root Startup time: 20.685 sec real, 12.460 sec
CPU
#
/ford/et17112/u/cleonell/cusr/local/Zope-3.1.0/lib/python/zope/i18n/locales/xmlfactory.pyc
matches
/ford/et17112/u/cleonell/cusr/local/Zope-3.1.0/lib/python/zope/i18n/locales/xmlfactory.py
import zope.i18n.locales.xmlfactory # precompiled from
/ford/et17112/u/cleonell/cusr/local/Zope-3.1.0/lib/python/zope/i18n/locales/xmlfactory.pyc
#
/ford/et17112/u/cleonell/cusr/local/lib/python2.3/xml/dom/expatbuilder.pyc
matches
/ford/et17112/u/cleonell/cusr/local/lib/python2.3/xml/dom/expatbuilder.py
import xml.dom.expatbuilder # precompiled from
/ford/et17112/u/cleonell/cusr/local/lib/python2.3/xml/dom/expatbuilder.pyc
Terminated (If I killed process or Bus Error under python 2.4.1/.2)

I don't know if the initial warning is significant or not.

I don't know if this is related or not, but the test suite (compiled
under python 2.3.5) hangs on testLargeBody:

6692/6990 ( 95.7%): testChunkingRequestWithoutContent
(zope.server.http.tests.test_httpserver.Tests) ... ok
6693/6990 ( 95.8%): testEchoResponse
(zope.server.http.tests.test_httpserver.Tests) ... ok
6694/6990 ( 95.8%): testLargeBody
(zope.server.http.tests.test_httpserver.Tests) ...

It gets caught in an infinite loop in the "loop" method (I killed it
after 55,000 iterations).

Any help or feedback is appreciated.  Thanks!

Chris Leonello
[EMAIL PROTECTED]


                
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to